<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<title>For Portland High basketball coach Joe Russo, a battle with cancer is providing his biggest win - CentralMaine.com</title>
<link rel="icon" type="image/png" href="https://www.centralmaine.com/wp-content/uploads/sites/2/2014/06/favicon.png" />
<link rel="apple-touch-icon" type="image/png" href="https://www.centralmaine.com/wp-content/uploads/sites/2/2014/06/apple-touch-icon-iphone.png" />
<link rel="apple-touch-icon" type="image/png" sizes="72x72" href="https://www.centralmaine.com/wp-content/uploads/sites/2/2014/06/apple-touch-icon-ipad.png" />
<link rel="apple-touch-icon" type="image/png" sizes="114x114" href="https://www.centralmaine.com/wp-content/uploads/sites/2/2014/06/apple-touch-icon-iphone-retina-display.png" />

<link href='https://fonts.googleapis.com/css?family=Lusitana:400,700' rel='stylesheet' type='text/css' />
<link href='https://fonts.googleapis.com/css?family=Open+Sans:400,700,800,600,300' rel='stylesheet' type='text/css' />
<link href='https://fonts.googleapis.com/css?family=Source+Serif+Pro' rel='stylesheet'>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />


<meta name="google-site-verification" content="DT-FwcrUrXtAltcTNXUsA7tR4Ha0CLErawYbGlkpg94" />


<script type="text/javascript">
		var _sf_async_config = _sf_async_config || {};

		/** CONFIGURATION START **/
		_sf_async_config.uid = 64520; // ACCOUNT NUMBER
		_sf_async_config.domain = 'centralmaine.com'; // DOMAIN
		_sf_async_config.flickerControl = false;
		_sf_async_config.useCanonical = true;
		/** CONFIGURATION END **/

		var _sf_startpt = (new Date()).getTime();
	</script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>


<meta name="description" content="Joe Russo is in remission after treatments for the disease that was diagnosed in February." />
<link rel="canonical" href="https://www.pressherald.com/2018/11/19/for-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win/" />
<link rel="publisher" href="https://plus.google.com/+Centralmaine/posts" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="For Portland High basketball coach Joe Russo, a battle with cancer is providing his biggest win" />
<meta property="og:description" content="Joe Russo is in remission after treatments for the disease that was diagnosed in February." />
<meta property="og:url" content="https://www.centralmaine.com/2018/11/19/for-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win/" />
<meta property="og:site_name" content="Kennebec Journal and Morning Sentinel" />
<meta property="article:publisher" content="https://www.facebook.com/mainenewspaper" />
<meta property="article:section" content="Sports" />
<meta property="article:published_time" content="2018-11-19T04:00:00-05:00" />
<meta property="article:modified_time" content="2018-11-19T08:29:30-05:00" />
<meta property="og:updated_time" content="2018-11-19T08:29:30-05:00" />
<meta property="og:image" content="https://multifiles.pressherald.com/uploads/sites/2/2018/11/858254-20181116_Coach926.jpg" />
<meta property="og:image:secure_url" content="https://multifiles.pressherald.com/uploads/sites/2/2018/11/858254-20181116_Coach926.jpg" />
<meta property="og:image:width" content="2894" />
<meta property="og:image:height" content="1961" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Joe Russo is in remission after treatments for the disease that was diagnosed in February." />
<meta name="twitter:title" content="For Portland High basketball coach Joe Russo, a battle with cancer is providing his biggest win - CentralMaine.com" />
<meta name="twitter:image" content="https://multifiles.pressherald.com/uploads/sites/2/2018/11/858254-20181116_Coach926.jpg" />

<link rel='dns-prefetch' href='//www.centralmaine.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//mainetoday-d.openx.net' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//multifiles.pressherald.com' />
<link rel="alternate" type="application/rss+xml" title="Kennebec Journal and Morning Sentinel &raquo; For Portland High basketball coach Joe Russo, a battle with cancer is providing his biggest win Comments Feed" href="https://www.centralmaine.com/2018/11/19/for-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.centralmaine.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='flexslider-css' href='https://www.centralmaine.com/wp-content/themes/mainetoday/assets/css/vendor/flexslider.css?ver=2.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='bxslider-css' href='https://www.centralmaine.com/wp-content/themes/mainetoday/assets/css/vendor/jquery.bxslider.css?ver=4.0' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css' href='https://www.centralmaine.com/wp-content/themes/mainetoday/assets/css/vendor/slick/slick.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='ticker-css' href='https://www.centralmaine.com/wp-content/themes/mainetoday/assets/css/vendor/ticker-style.css?ver=1530269452' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css?ver=4.9.8' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='ie-eight-css'  href='https://www.centralmaine.com/wp-content/themes/mainetoday/assets/css/ie8.css?ver=1530269452' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='mainetoday-css' href='https://www.centralmaine.com/wp-content/themes/mainetoday/assets/css/mainetoday.css?ver=1540483649' type='text/css' media='all' />
<link rel='stylesheet' id='mainetoday_centralmaine-css' href='https://www.centralmaine.com/wp-content/themes/mainetoday-centralmaine/assets/css/mtm-child.min.css?ver=1530269452' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.centralmaine.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.9' type='text/css' media='all' />
<script type='text/javascript' src='https://www.centralmaine.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20150408'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/handlebars.js/4.0.10/handlebars.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='//mainetoday-d.openx.net/w/1.0/jstag?nc=6119-centralmaine&#038;ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mtmads = {"dfpId":"6119","adInjection":"post","postCategories":["sports","highschoolsports"],"pageType":"Article"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-content/themes/mainetoday/assets/js/ads.js?ver=4.9.8'></script>
<link rel='https://api.w.org/' href='https://www.centralmaine.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.centralmaine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.centralmaine.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://www.centralmaine.com/?p=1128310' />
<link rel="alternate" type="application/json+oembed" href="https://www.centralmaine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.centralmaine.com%2F2018%2F11%2F19%2Ffor-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.centralmaine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.centralmaine.com%2F2018%2F11%2F19%2Ffor-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win%2F&#038;format=xml" />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<style type='text/css'>img#wpstats{display:none}</style> <meta property="fb:app_id" content="754222714628811">
<script type="text/javascript">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</script><script type="text/javascript">var adSlotToAdd = []; //array to hold values for as Slots.

/**
 * Every five paragraphs, insert ads into the article content.
 */
googletag.cmd.push( function() {

	mode = mtmads.adInjection;

	switch ( mode ) {
		case 'post':
			var objects = document.querySelectorAll( '.post-content > p' );
			var insertPoint = 6;
			break;
		case 'category':
			var objects = document.querySelectorAll( '.mtm-river .river li, .basic-category-list li' );
			var insertPoint = 5;
			break;
		default:
			return;
	}

	var objectCount = objects.length; // total number of P nodes.
	var count = 1; // initialize count.
	var position = 6;
	var fallbackDomain = window.location.host.replace( /^(www|stage)\./i, '').replace('.test', '.com' );

	// Sun Journal has a unique ad domain.
	if ( 'sunjournal.com' === fallbackDomain ) {
		fallbackDomain = 'smg/sunjournal.com';
	}
	
	while ( position < objectCount ) {

		adTargetName = '/6119/' + ( typeof AdSection !== 'undefined' ? AdSection : fallbackDomain );

		var myNode = objects[position]; //select the node for insertion.

		// Do not display the ad if it is too close to the end of the article.
		if ( objectCount - position < 2 ) {
			return;
		}

		if ( ( 'P' === myNode.previousElementSibling.tagName && 'post' === mode) || ( 'LI' === myNode.previousElementSibling.tagName && 'category' === mode) ) {

			const adnotice = document.createElement( 'span' );
				adnotice.setAttribute( 'class', 'before-injected-ad' );
				adnotice.textContent = 'Advertisement';

			const adslot = document.createElement( 'div' );
				adslot.setAttribute( 'id', 'adslot' + count );
				adslot.setAttribute( 'style', 'display: block; margin:0 auto; text-align:center; width:302px;' );
	
			myNode.insertAdjacentElement( 'beforebegin', adnotice );
			adnotice.insertAdjacentElement( 'afterend', adslot );

			adSlotToAdd.push( 'adslot' + count ); //add slot name.

			var slotName = 'adslot' + count;

			mtmads.slotName = googletag.defineSlot( adTargetName, [ ['fluid'], [300, 250] ], slotName )
				.setTargeting('pos', [ 'i','i' +  count ])
				.addService( googletag.pubads() );
			
			googletag.display( slotName );
		}

		count = count + 1;  //increment values.
		position = count * insertPoint;
	}
});
</script><script type="text/javascript">AdSection = 'centralmaine.com/news';
googletag.cmd.push(function() {

mtmads.pos_1_atf_728x90 = googletag.defineSlot("/6119/centralmaine.com/news/article", [320, 50], "pos_1_atf_728x90").setTargeting("pos", "1").defineSizeMapping(mtmads.sizeMapping.pos1).addService(googletag.pubads());

mtmads.pos_2_atf_300x250 = googletag.defineSlot("/6119/centralmaine.com/news/article", [300,250], "pos_2_atf_300x250").setTargeting("pos", "2").defineSizeMapping(mtmads.sizeMapping.pos2).addService(googletag.pubads());

mtmads.pos_3_btf_300x250_300x600 = googletag.defineSlot("/6119/centralmaine.com/news/article", [300,250], "pos_3_btf_300x250_300x600").setTargeting("pos", "3").defineSizeMapping(mtmads.sizeMapping.pos3).addService(googletag.pubads());

if ( viewportwidth > 730 ) {
mtmads.pos_btf_728x90 = googletag.defineSlot("/6119/centralmaine.com/news/article", [728,90], "pos_btf_728x90").setTargeting("pos", "4").defineSizeMapping(mtmads.sizeMapping.pos4).addService(googletag.pubads());
}

if ( viewportwidth > 767 ) {
mtmads.pos_btf_8_300x250 = googletag.defineSlot("/6119/centralmaine.com/news/article", [300,250], "pos_btf_8_300x250").setTargeting("pos", "8").defineSizeMapping(mtmads.sizeMapping.btfmr).addService(googletag.pubads());
}

mtmads.native_ad = googletag.defineSlot("/6119/centralmaine.com/news/article", ['fluid'], "native_ad").setTargeting("pos", "native").addService(googletag.pubads());

mtmads.pos_f_320x50 = googletag.defineSlot("/6119/centralmaine.com/news/article", [300,50], "pos_f_320x50").setTargeting("pos", "f").defineSizeMapping(mtmads.sizeMapping.footer).addService(googletag.pubads());
});</script>


<script>
jQuery(function(){
var now = new Date();
var viewCountReg = new RegExp('mspan_paywall_views_'+now.getMonth()+'=(\\d+)','i');
window.dataLayer = window.dataLayer || [];
  window.dataLayer.push( {
  	 'event': 'datalayer-loaded',
  	 'companyName' : 'Maine Today',
	  'categoryArray': 'sports,highschoolsports',
	  'tagArray': 'N/A',
	  'loggedIn':   (document.cookie.match(/MSPAN_Paywall_user/i) ? 'logged in' : 'logged out'),
     'pagesToPaywall': undefined !== window.MSPAN ? window.MSPAN.Paywall.totalViews() : -1,
     'orientation': window.innerHeight > window.innerWidth ? 'Portrait' : 'Landscape',
	  'contentType': 'Article',
	  'paywall_status': /MSPAN_Paywall_user/.test(document.cookie),
	  'paywall_hit_count': (viewCountReg.test(document.cookie) ? document.cookie.match( viewCountReg )[1] : '0'),
	  'private-mode':  privateBrowsing(),
	  'verifiedAds': (typeof VerifiedAds === 'string' ? true : false)
  });
});
</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
			new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
			j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
			'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
		})(window,document,'script','dataLayer','GTM-TZKX8X');</script>


<meta property="fb:pages" content="" />

<meta name="onesignal" content="wordpress-plugin" />
<link rel="manifest" href="https://www.centralmaine.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id=" />
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.centralmaine.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'dc6d787c-78fd-40f1-9957-09eba5bf9578';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.centralmaine.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.3145fc89-5d6b-4727-99ef-e9ab80472582";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'small';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

</head>
<body class="post-template-default single single-post postid-1128310 single-format-standard active-paywall story-head">
<div class="paywall-banner">
<p>
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/pph-icon.png" style="vertical-align:middle;">
<span></span>
<span>
<a href="https://www.centralmaine.com/login">Sign in</a> or <a href="https://www.centralmaine.com/order/?ref=paywall-stub">Subscribe</a> </span>
<span class="expand-extra-messaging extra-closed">See Offers</span>
<span class="close-slidedown">
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/close-icon.png" style="vertical-align:middle;">
</span>
</p>
<div class="special-messaging">
<p></p>
<img src="" />
<br>
</div>
</div>

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TZKX8X"
					  height="0" width="0" style="display:none;visibility:hidden"></iframe>
	</noscript>


<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	ga('create', 'UA-10862716-2', 'auto', {'allowLinker': true});
	ga('require', 'displayfeatures');
	ga('require', 'linker');
	ga('linker:autoLink', ['cmniservices.newscyclecloud.com']);

	// Custom dimensions for analytics
	jQuery(function( $ ){
		var customDimensions = {};
		var date = new Date();
		var viewCountReg = new RegExp('MSPAN_Paywall_views_' + date.getMonth().toString() + '=([0-9]+)');
		
		var section = (function(){
		   var $sectionTitles = $('.section');
		   var reg = {
		      word: /\w/,
		      space: /^\s+|\s+$/g
		   };
		   var tmpText;

		   for(var i = 0; i < $sectionTitles.length; i++){
		      tmpText = $sectionTitles.eq(i).text().replace(reg.space, '');
		      if(tmpText.match(reg.word)){
		         return tmpText;
		      }
		   }
		   return "unknown section";
		}());

		customDimensions.dimension2 = section;
		customDimensions.dimension3 = 'logged ' + (document.cookie.match(/MSPAN_Paywall_user/i) ? 'in' : 'out');

		if( typeof AdSection !== "undefined" ) {
			customDimensions.dimension6 = AdSection;
		}

		if( undefined !== window.MSPAN ) {
			customDimensions.dimension4 = window.MSPAN.Paywall.totalViews();
		}

		if(window.innerHeight > window.innerWidth) {
			customDimensions.dimension5 = 'Portrait';
		} else {
			customDimensions.dimension5 = 'Landscape';
		}

		customDimensions.dimension7 = 'sports,highschoolsports';					customDimensions.dimension8 = Utils.getAuthor();
				
		/*new analytics code example */
		
			customDimensions.dimension9 = /MSPAN_Paywall_user/.test(document.cookie); /*variable for paywall status */
			customDimensions.dimension10 = (viewCountReg.test(document.cookie) ? document.cookie.match( viewCountReg )[1] : '0'); /*variable for paywall hit count */
			customDimensions.dimension11 = privateBrowsing();/* PrivateMode (on|off) */
			customDimensions.dimension12 = '';/* verifiedAds (active|inactive) it would be good to get negative values so that we have the total measured - because to get an accurate percentage we need the total universe and a lot of pages -obits . - don't send these signals) */
			customDimensions.dimension14 = 
			false;
		ga('send', 'pageview', customDimensions);
		ga('set', 'anonymizeIp', true);


	});
</script>

<div class="mtm-utility-launch">
<div class="search-mobile slide">
<form method="get" action="https://www.centralmaine.com/" id="searchform" class="search-mobile-form">
<input type="text" class="search-box" name="s" id="s" placeholder="What are you looking for?" onFocus="this.placeholder = ''" onBlur="this.placeholder = 'Looking for something?'">
<input type="submit" value="" class="search-submit-off" id="searchsubmit">
</form>
</div>

<div class="utility-menu-skin">
<ul id="utility-menu" class="menu"><li id="menu-item-724402" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-724402 depth-0"><a href="https://www.centralmaine.com/news/localstate/">Local &amp; State</a>
<ul class="sub-menu">
<li id="menu-item-801505" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-801505 depth-1"><a href="https://www.centralmaine.com/news/localstate/">Local &amp; State home</a></li>
<li id="menu-item-724405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-724405 depth-1"><a href="https://www.centralmaine.com/news/mainecrime/">Maine Crime</a></li>
<li id="menu-item-861272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-861272 depth-1"><a href="https://www.centralmaine.com/tag/police-log/">Police Logs</a></li>
<li id="menu-item-822678" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-822678 depth-1"><a href="https://www.centralmaine.com/news/">All News</a></li>
<li id="menu-item-801512" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-801512 depth-1"><a href="https://www.centralmaine.com/news/business/">Business</a></li>
<li id="menu-item-724403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-724403 depth-1"><a href="https://www.centralmaine.com/news/nationworld/">Nation &amp; World</a></li>
</ul>
</li>
<li id="menu-item-724410" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-724410 depth-0"><a href="https://www.centralmaine.com/politics/">Politics</a>
<ul class="sub-menu">
<li id="menu-item-993466" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-993466 depth-1"><a href="https://www.centralmaine.com/news/politics/">Politics home</a></li>
<li id="menu-item-993458" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-993458 depth-1"><a href="https://www.centralmaine.com/tag/election-2018/">Election 2018</a></li>
<li id="menu-item-993462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-993462 depth-1"><a href="https://www.centralmaine.com/tag/governor-2018/">Governor 2018</a></li>
</ul>
</li>
<li id="menu-item-810988" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-810988 depth-0"><a href="https://www.centralmaine.com/sports/">Sports</a>
<ul class="sub-menu">
<li id="menu-item-810997" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-810997 depth-1"><a href="https://www.centralmaine.com/sports/highschoolsports/">High School Sports</a></li>
<li id="menu-item-724493" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-724493 depth-1"><a href="https://www.centralmaine.com/sports/">Sports Home</a></li>
<li id="menu-item-724412" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-724412 depth-1"><a href="https://www.centralmaine.com/sports/college/">College</a></li>
<li id="menu-item-724414" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-724414 depth-1"><a href="https://www.centralmaine.com/sports/outdoors/">Outdoors</a></li>
</ul>
</li>
<li id="menu-item-801486" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-801486 depth-0"><a href="https://www.centralmaine.com/community/">Community</a>
<ul class="sub-menu">
<li id="menu-item-815379" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-815379 depth-1"><a href="https://www.centralmaine.com/community/">Community home</a></li>
<li id="menu-item-1070490" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1070490 depth-1"><a href="https://www.centralmaine.com/life/calendar/">Event Calendar</a></li>
<li id="menu-item-801487" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-801487 depth-1"><a href="https://www.centralmaine.com/celebrations/">Celebrations</a></li>
</ul>
</li>
<li id="menu-item-724408" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-724408 depth-0"><a href="https://www.centralmaine.com/opinion/">Opinion</a>
<ul class="sub-menu">
<li id="menu-item-724494" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-724494 depth-1"><a href="https://www.centralmaine.com/opinion/">Opinion Home</a></li>
<li id="menu-item-724409" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-724409 depth-1"><a href="https://www.centralmaine.com/opinion/letters/">Letters to the Editor</a></li>
<li id="menu-item-802901" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-802901 depth-1"><a href="https://www.centralmaine.com/opinion/columnists-opinion/">Columnists</a></li>
</ul>
</li>
<li id="menu-item-724416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-724416 depth-0"><a href="https://www.centralmaine.com/lifestyle/">Lifestyle</a>
<ul class="sub-menu">
<li id="menu-item-1070482" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1070482 depth-1"><a href="https://www.centralmaine.com/lifestyle/">Lifestyle home</a></li>
<li id="menu-item-1070494" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1070494 depth-1"><a href="https://www.centralmaine.com/life/calendar/">Event Calendar</a></li>
<li id="menu-item-1070486" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1070486 depth-1"><a href="https://www.centralmaine.com/life/food/">Food</a></li>
<li id="menu-item-724420" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-724420 depth-1"><a href="https://www.centralmaine.com/foodanddining/source/">Sustainable Living</a></li>
</ul>
</li>
<li id="menu-item-724423" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-724423 depth-0"><a href="http://obituaries.centralmaine.com">Obituaries</a></li>
<li id="menu-item-724426" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-724426 depth-0"><a href="http://www.pressherald.com">Pressherald.com</a></li>
<li id="menu-item-724427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-724427 depth-0"><a href="http://mainetoday.com">Mainetoday.com</a></li>
<li id="menu-item-724422" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-724422 depth-0"><a href="http://voices.centralmaine.com/">Events</a></li>
<li id="menu-item-724441" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-724441 depth-0"><a href="#">Classified</a>
<ul class="sub-menu">
<li id="menu-item-977062" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-977062 depth-1"><a target="_blank" href="http://mainejobs.com">MaineJobs</a></li>
<li id="menu-item-724442" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-724442 depth-1"><a href="https://www.centralmaine.com/realestate/">Real Estate</a></li>
<li id="menu-item-724443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-724443 depth-1"><a href="https://www.centralmaine.com/local-offers/">Local Offers</a></li>
</ul>
</li>
<li id="menu-item-724428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-724428 depth-0"><a href="http://mainetoday.mycapture.com/mycapture/category.asp?CategoryID=55532">Purchase Photos</a></li>
<li id="menu-item-724429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-724429 depth-0"><a href="http://www.mainenotices.com/?utm_source=centralmaine.com&#038;utm_medium=referral&#038;utm_campaign=menu">Public Notices</a></li>
<li id="menu-item-724430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-724430 depth-0"><a href="#">Puzzles</a>
<ul class="sub-menu">
<li id="menu-item-724432" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-724432 depth-1"><a href="https://www.centralmaine.com/sudoku/">Sudoku</a></li>
<li id="menu-item-724436" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-724436 depth-1"><a href="https://www.centralmaine.com/crossword/">Crossword</a></li>
</ul>
</li>
<li id="menu-item-724437" class="myaccount-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-724437 depth-0"><a href="https://www.centralmaine.com/e-edition/">e-Editions</a></li>
<li id="menu-item-724438" class="myaccount-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-724438 depth-0"><a href="https://www.centralmaine.com/newsletters/">Newsletters</a></li>
<li id="menu-item-724439" class="myaccount-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-724439 depth-0"><a href="https://cmniservices.newscyclecloud.com/cmo_lsj-c-cmdb-mtm-01/subscriber/web/signin.html">My Account</a></li>
<li id="menu-item-724440" class="myaccount-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-724440 depth-0"><a href="https://www.centralmaine.com/support/">Support</a>
<ul class="sub-menu">
<li id="menu-item-724444" class="myaccount-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-724444 depth-1"><a href="https://www.centralmaine.com/support/">Home Delivery Help</a></li>
<li id="menu-item-724445" class="myaccount-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-724445 depth-1"><a href="https://www.centralmaine.com/support/">FAQ</a></li>
<li id="menu-item-724446" class="myaccount-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-724446 depth-1"><a href="https://www.centralmaine.com/reader-services/">Reader Services</a></li>
<li id="menu-item-724447" class="myaccount-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-724447 depth-1"><a href="https://www.centralmaine.com/contact/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-724448" class="subscribe-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-724448 depth-0"><a href="https://www.centralmaine.com/order/">Subscribe</a></li>
<li id="menu-item-724449" class="subscribe-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-724449 depth-0"><a href="https://www.centralmaine.com/advertising/">Advertise</a></li>
<li id="menu-item-724450" class="myaccount-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-724450 depth-0"><a href="https://www.centralmaine.com/special-sections/">Special Sections</a></li>
</ul>
</div>
<div class="utility-menu-skin-cover">
</div>
</div>
<div class="main-navigation" role="navigation">
<div class="site-home-logo">Centralmaine
<a href="https://www.centralmaine.com">Home</a>
</div>
<div class="main-menu-togglers" style="color:#fff">
<div class="menu-expand">
<div id="nav-icon3"><span></span><span></span><span></span><span></span></div>
<div>Menu</div>
</div>
</div>
<ul id="main-top-menu" class="menu"><li id="menu-item-414875" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-414875 depth-0"><a href="https://www.centralmaine.com/news/localstate/">Local &amp; State</a>
<div class="hover-navigation localstate">
<div class="featured-headline">
<div class="image-crop">
<a href="https://www.centralmaine.com/2018/11/19/sisters-taking-up-indian-mascot-issue-with-skowhegan-school-board/" onclick="ga('send', 'event', 'click', 'hovernav | localstate', 'Sisters taking up Indian mascot issue with Skowhegan school board');">
<img width="250" height="250" src="https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128906_576759-20181119-indian-1-250x250.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128906_576759-20181119-indian-1-250x250.jpg 250w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128906_576759-20181119-indian-1-32x32.jpg 32w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128906_576759-20181119-indian-1-50x50.jpg 50w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128906_576759-20181119-indian-1-64x64.jpg 64w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128906_576759-20181119-indian-1-96x96.jpg 96w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128906_576759-20181119-indian-1-128x128.jpg 128w" sizes="(max-width: 250px) 100vw, 250px" /> </a>
</div>
<div class="category">
Local &amp; State </div>
<div class="nav-headline">
<a href="https://www.centralmaine.com/2018/11/19/sisters-taking-up-indian-mascot-issue-with-skowhegan-school-board/" onclick="ga('send', 'event', 'click', 'hovernav | localstate', 'Sisters taking up Indian mascot issue with Skowhegan school board');">
Sisters taking up Indian mascot issue with Skowhegan school board </a>
</div>
<div class="nav-excerpt"></div>
</div>
<div class="more-headlines">
<ul>
<li><h2>More Headlines</h2></li>
<li>
<a href="https://www.centralmaine.com/2018/11/19/bronx-ny-man-arrested-in-nh-on-augusta-drug-charges/" onclick="ga('send', 'event', 'click', 'hovernav | localstate', 'Bronx, NY, man arrested in NH on Augusta drug charges');">
Bronx, NY, man arrested in NH on Augusta drug charges </a>
</li>
<li>
<a href="https://www.centralmaine.com/2018/11/19/university-of-maine-starts-on-search-for-umf-president/" onclick="ga('send', 'event', 'click', 'hovernav | localstate', 'University of Maine System starts search for UMF president');">
University of Maine System starts search for UMF president </a>
</li>
</ul>
</div>
<div class="more-in">
<ul>
<li><h2>More in Local &amp; State</h2></li>
<li>
<a href="https://www.centralmaine.com/news/mainecrime/">
Maine Crime </a>
</li>
<li>
<a href="https://www.centralmaine.com/tag/police-log/">
Police Logs </a>
</li>
<li>
<a href="https://www.centralmaine.com/news/localstate/">
Choose A Town </a>
</li>
<li>
<a href="https://www.centralmaine.com/news/">
All News </a>
</li>
<li>
<a href="https://www.centralmaine.com/news/business/">
Business </a>
</li>
<li>
<a href="https://www.centralmaine.com/news/nationworld/">
Nation &amp; World </a>
</li>
</ul>
</div>
</div>
</li>
<li id="menu-item-993446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-993446 depth-0"><a href="https://www.centralmaine.com/politics/">Politics</a>
<div class="hover-navigation politics">
<div class="featured-headline">
<div class="image-crop">
<a href="https://www.centralmaine.com/2018/11/19/3-democratic-senators-sue-over-whitakers-appointment-as-ag/" onclick="ga('send', 'event', 'click', 'hovernav | politics', '3 Democratic senators sue over Whitaker&#8217;s appointment as AG');">
<img width="250" height="250" src="https://multifiles.pressherald.com/uploads/sites/2/2018/11/1680674_Trump_Whitaker_07089.jpg-a4-250x250.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://multifiles.pressherald.com/uploads/sites/2/2018/11/1680674_Trump_Whitaker_07089.jpg-a4-250x250.jpg 250w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1680674_Trump_Whitaker_07089.jpg-a4-32x32.jpg 32w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1680674_Trump_Whitaker_07089.jpg-a4-50x50.jpg 50w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1680674_Trump_Whitaker_07089.jpg-a4-64x64.jpg 64w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1680674_Trump_Whitaker_07089.jpg-a4-96x96.jpg 96w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1680674_Trump_Whitaker_07089.jpg-a4-128x128.jpg 128w" sizes="(max-width: 250px) 100vw, 250px" /> </a>
</div>
<div class="category">
Politics </div>
<div class="nav-headline">
<a href="https://www.centralmaine.com/2018/11/19/3-democratic-senators-sue-over-whitakers-appointment-as-ag/" onclick="ga('send', 'event', 'click', 'hovernav | politics', '3 Democratic senators sue over Whitaker&#8217;s appointment as AG');">
3 Democratic senators sue over Whitaker&#8217;s appointment as AG </a>
</div>
<div class="nav-excerpt"></div>
</div>
<div class="more-headlines">
<ul>
<li><h2>More Headlines</h2></li>
<li>
<a href="https://www.centralmaine.com/2018/11/18/maine-democratic-party-leaders-stepping-down/" onclick="ga('send', 'event', 'click', 'hovernav | politics', 'Maine Democratic Party leaders stepping down');">
Maine Democratic Party leaders stepping down </a>
</li>
<li>
<a href="https://www.centralmaine.com/2018/11/18/final-results-show-republican-gov-scott-leads-in-us-senate-race/" onclick="ga('send', 'event', 'click', 'hovernav | politics', 'Democrat Nelson concedes to Gov. Scott in Florida Senate race');">
Democrat Nelson concedes to Gov. Scott in Florida Senate race </a>
</li>
</ul>
</div>
<div class="more-in">
<ul>
<li><h2>More in Politics</h2></li>
<li>
<a href="https://www.centralmaine.com/tag/election-2018/">
Election 2018 </a>
</li>
<li>
<a href="https://www.centralmaine.com/tag/governor-2018/">
Governor 2018 </a>
</li>
</ul>
</div>
</div>
</li>
<li id="menu-item-986310" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-986310 depth-0"><a href="https://www.centralmaine.com/sports/highschoolsports/">High School Sports</a>
<div class="hover-navigation highschoolsports">
<div class="featured-headline">
<div class="image-crop">
<a href="https://www.centralmaine.com/2018/11/19/for-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win/" onclick="ga('send', 'event', 'click', 'hovernav | highschoolsports', 'For Portland High basketball coach Joe Russo, a battle with cancer is providing his biggest win');">
<img width="250" height="250" src="https://multifiles.pressherald.com/uploads/sites/2/2018/11/858254-20181116_Coach926-250x250.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://multifiles.pressherald.com/uploads/sites/2/2018/11/858254-20181116_Coach926-250x250.jpg 250w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/858254-20181116_Coach926-32x32.jpg 32w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/858254-20181116_Coach926-50x50.jpg 50w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/858254-20181116_Coach926-64x64.jpg 64w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/858254-20181116_Coach926-96x96.jpg 96w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/858254-20181116_Coach926-128x128.jpg 128w" sizes="(max-width: 250px) 100vw, 250px" /> </a>
</div>
<div class="category">
Varsity Maine </div>
<div class="nav-headline">
<a href="https://www.centralmaine.com/2018/11/19/for-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win/" onclick="ga('send', 'event', 'click', 'hovernav | highschoolsports', 'For Portland High basketball coach Joe Russo, a battle with cancer is providing his biggest win');">
For Portland High basketball coach Joe Russo, a battle with cancer is providing his biggest win </a>
</div>
<div class="nav-excerpt"></div>
</div>
<div class="more-headlines">
<ul>
<li><h2>More Headlines</h2></li>
<li>
<a href="https://www.centralmaine.com/2018/11/17/football-marshwood-rolls-to-second-straight-title/" onclick="ga('send', 'event', 'click', 'hovernav | highschoolsports', 'Football: Marshwood rolls to second straight title');">
Football: Marshwood rolls to second straight title </a>
</li>
<li>
<a href="https://www.centralmaine.com/2018/11/17/football-state-championship-notes-best-friends-hoist-gold-ball/" onclick="ga('send', 'event', 'click', 'hovernav | highschoolsports', 'Football state championship notes: Best friends hoist gold ball');">
Football state championship notes: Best friends hoist gold ball </a>
</li>
</ul>
</div>
<div class="more-in">
<ul>
<li><h2>More in Varsity Maine</h2></li>
<li>
<a href="https://www.centralmaine.com/sports/">
Sports </a>
</li>
<li>
<a href="https://www.centralmaine.com/sports/college/">
College </a>
</li>
<li>
<a href="https://www.centralmaine.com/sports/outdoors/">
Outdoors </a>
</li>
</ul>
</div>
</div>
</li>
<li id="menu-item-5464" class="opinion menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5464 depth-0"><a href="https://www.centralmaine.com/opinion/">Opinion</a>
<div class="hover-navigation opinion">
<div class="featured-headline">
<div class="image-crop">
<a href="https://www.centralmaine.com/2018/11/19/our-view-stop-slow-walking-bids-for-citizenship/" onclick="ga('send', 'event', 'click', 'hovernav | opinion', 'Our View: Stop slow-walking bids for citizenship');">
<img width="250" height="250" src="https://multifiles.pressherald.com/uploads/sites/2/2018/11/1127650_4017_20160408_naturalizat_3-250x250.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://multifiles.pressherald.com/uploads/sites/2/2018/11/1127650_4017_20160408_naturalizat_3-250x250.jpg 250w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1127650_4017_20160408_naturalizat_3-32x32.jpg 32w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1127650_4017_20160408_naturalizat_3-50x50.jpg 50w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1127650_4017_20160408_naturalizat_3-64x64.jpg 64w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1127650_4017_20160408_naturalizat_3-96x96.jpg 96w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1127650_4017_20160408_naturalizat_3-128x128.jpg 128w" sizes="(max-width: 250px) 100vw, 250px" /> </a>
</div>
<div class="category">
Opinion </div>
<div class="nav-headline">
<a href="https://www.centralmaine.com/2018/11/19/our-view-stop-slow-walking-bids-for-citizenship/" onclick="ga('send', 'event', 'click', 'hovernav | opinion', 'Our View: Stop slow-walking bids for citizenship');">
Our View: Stop slow-walking bids for citizenship </a>
</div>
<div class="nav-excerpt"></div>
</div>
<div class="more-headlines">
<ul>
<li><h2>More Headlines</h2></li>
<li>
<a href="https://www.centralmaine.com/2018/11/19/community-compass-holidays-a-risky-time-for-teen-drinking/" onclick="ga('send', 'event', 'click', 'hovernav | opinion', 'Community Compass: Holidays a risky time for teen drinking');">
Community Compass: Holidays a risky time for teen drinking </a>
</li>
<li>
<a href="https://www.centralmaine.com/2018/11/19/maine-compass-add-food-lessons-to-college-curriculum/" onclick="ga('send', 'event', 'click', 'hovernav | opinion', 'Maine Compass: Add food lessons to college curriculum');">
Maine Compass: Add food lessons to college curriculum </a>
</li>
</ul>
</div>
<div class="more-in">
<ul>
<li><h2>More in Opinion</h2></li>
<li>
<a href="https://www.centralmaine.com/opinion/editorials/">
Editorials </a>
</li>
<li>
<a href="https://www.centralmaine.com/opinion/letters/">
Letters to the Editor </a>
</li>
<li>
<a href="https://www.centralmaine.com/opinion/columnists-opinion/">
Columnists </a>
</li>
</ul>
</div>
</div>
</li>
<li id="menu-item-801483" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-801483 depth-0"><a href="https://www.centralmaine.com/community/">Community</a>
<div class="hover-navigation community">
<div class="featured-headline">
<div class="category">
Community </div>
<div class="nav-headline">
<a href="https://www.centralmaine.com/2018/11/19/grace-christian-academy-first-quarter-honor-roll/" onclick="ga('send', 'event', 'click', 'hovernav | community', 'Grace Christian Academy first-quarter honor roll');">
Grace Christian Academy first-quarter honor roll </a>
</div>
<div class="nav-excerpt"></div>
</div>
<div class="more-headlines">
<ul>
<li><h2>More Headlines</h2></li>
<li>
<a href="https://www.centralmaine.com/2018/11/19/international-harvest-festival-set-for-nov-29/" onclick="ga('send', 'event', 'click', 'hovernav | community', 'International Harvest Festival set for Nov. 29');">
International Harvest Festival set for Nov. 29 </a>
</li>
<li>
<a href="https://www.centralmaine.com/2018/11/19/waterville-senior-high-school-honor-roll-16/" onclick="ga('send', 'event', 'click', 'hovernav | community', 'Waterville Senior High School honor roll');">
Waterville Senior High School honor roll </a>
</li>
</ul>
</div>
<div class="more-in">
<ul>
<li><h2>More in Community</h2></li>
<li>
<a href="https://www.centralmaine.com/life/calendar/">
Event Calendar </a>
</li>
<li>
<a href="https://www.centralmaine.com/celebrations/">
Celebrations </a>
</li>
</ul>
</div>
</div>
</li>
<li id="menu-item-287665" class="obituaries-2 menu-item menu-item-type-custom menu-item-object-custom menu-item-287665 depth-0"><a href="http://obituaries.centralmaine.com/obituaries/mainetoday-centralmaine/">Obituaries</a></li>
<li id="menu-item-53375" class="lifestyle menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-53375 depth-0"><a href="https://www.centralmaine.com/lifestyle/">Lifestyle</a>
<div class="hover-navigation lifestyle">
<div class="featured-headline">
<div class="image-crop">
<a href="https://www.centralmaine.com/2018/11/19/sensational-sampler-of-2018-cant-miss-holiday-events/" onclick="ga('send', 'event', 'click', 'hovernav | lifestyle', 'Sensational sampler of 2018 can’t-miss holiday events');">
<img width="250" height="250" src="https://multifiles.pressherald.com/uploads/sites/2/2018/11/279906-Harbor-Lights-Festival-1-250x250.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://multifiles.pressherald.com/uploads/sites/2/2018/11/279906-Harbor-Lights-Festival-1-250x250.jpg 250w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/279906-Harbor-Lights-Festival-1-32x32.jpg 32w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/279906-Harbor-Lights-Festival-1-50x50.jpg 50w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/279906-Harbor-Lights-Festival-1-64x64.jpg 64w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/279906-Harbor-Lights-Festival-1-96x96.jpg 96w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/279906-Harbor-Lights-Festival-1-128x128.jpg 128w" sizes="(max-width: 250px) 100vw, 250px" /> </a>
</div>
<div class="category">
Lifestyle </div>
<div class="nav-headline">
<a href="https://www.centralmaine.com/2018/11/19/sensational-sampler-of-2018-cant-miss-holiday-events/" onclick="ga('send', 'event', 'click', 'hovernav | lifestyle', 'Sensational sampler of 2018 can’t-miss holiday events');">
Sensational sampler of 2018 can’t-miss holiday events </a>
</div>
<div class="nav-excerpt"></div>
</div>
<div class="more-headlines">
<ul>
<li><h2>More Headlines</h2></li>
<li>
<a href="https://www.centralmaine.com/2018/11/19/many-apply-few-are-chosen-as-finalists-to-become-maines-next-episcopal-bishop/" onclick="ga('send', 'event', 'click', 'hovernav | lifestyle', 'Many apply, few are chosen as finalists to become Maine&#8217;s next Episcopal bishop');">
Many apply, few are chosen as finalists to become Maine&#8217;s next Episcopal bishop </a>
</li>
<li>
<a href="https://www.centralmaine.com/2018/11/18/recipe-soft-boiled-eggs-with-prosciutto-and-cheese-soldiers/" onclick="ga('send', 'event', 'click', 'hovernav | lifestyle', 'Recipe: Soft-Boiled Eggs with Prosciutto and Cheese Soldiers');">
Recipe: Soft-Boiled Eggs with Prosciutto and Cheese Soldiers </a>
</li>
</ul>
</div>
<div class="more-in">
<ul>
<li><h2>More in Lifestyle</h2></li>
<li>
<a href="https://www.centralmaine.com/life/calendar/">
Event Calendar </a>
</li>
<li>
<a href="https://www.centralmaine.com/life/food/">
Food </a>
</li>
<li>
<a href="https://www.centralmaine.com/life/books/">
Books </a>
</li>
<li>
<a href="https://www.pressherald.com/food-and-dining-/source/">
Sustainable Living </a>
</li>
<li>
<a href="https://www.centralmaine.com/sudoku/">
Sudoku </a>
</li>
<li>
<a href="https://www.centralmaine.com/crossword/">
Crossword </a>
</li>
</ul>
</div>
</div>
</li>
<li id="menu-item-476996" class="local-offers menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-476996 depth-0"><a href="https://www.centralmaine.com/local-offers/">Local Offers</a>
<div class="hover-navigation local-offers">
<div class="featured-headline">
<div class="category">
Local Offers </div>
<div class="nav-headline">
<a href="https://www.centralmaine.com/2015/02/07/test/" onclick="ga('send', 'event', 'click', 'hovernav | local-offers', 'Test');">
Test </a>
</div>
<div class="nav-excerpt"></div>
</div>
<div class="more-headlines">
<ul>
<li><h2>More Headlines</h2></li>
</ul>
</div>
<div class="more-in">
<ul>
<li><h2>More in Local Offers</h2></li>
<li>
<a href="https://centralmaine.villagesoup.com">
test </a>
</li>
</ul>
</div>
</div>
</li>
<li id="menu-item-416279" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-416279 depth-0"><a href="https://www.centralmaine.com/realestate/">Real Estate</a>
<div class="hover-navigation realestate">
<div class="featured-headline">
<div class="image-crop">
<a href="https://www.centralmaine.com/2018/06/30/portland-planning-board-gets-ball-rolling-on-commercial-street-hotel-condo-project/" onclick="ga('send', 'event', 'click', 'hovernav | realestate', 'Portland Planning Board gets ball rolling on Commercial Street hotel, condo project');">
<img width="250" height="250" src="https://multifiles.pressherald.com/uploads/sites/2/2018/06/1421951_293100-rendering383Commerci-250x250.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://multifiles.pressherald.com/uploads/sites/2/2018/06/1421951_293100-rendering383Commerci-250x250.jpg 250w, https://multifiles.pressherald.com/uploads/sites/2/2018/06/1421951_293100-rendering383Commerci-32x32.jpg 32w, https://multifiles.pressherald.com/uploads/sites/2/2018/06/1421951_293100-rendering383Commerci-50x50.jpg 50w, https://multifiles.pressherald.com/uploads/sites/2/2018/06/1421951_293100-rendering383Commerci-64x64.jpg 64w, https://multifiles.pressherald.com/uploads/sites/2/2018/06/1421951_293100-rendering383Commerci-96x96.jpg 96w, https://multifiles.pressherald.com/uploads/sites/2/2018/06/1421951_293100-rendering383Commerci-128x128.jpg 128w" sizes="(max-width: 250px) 100vw, 250px" /> </a>
</div>
<div class="category">
Real Estate </div>
<div class="nav-headline">
<a href="https://www.centralmaine.com/2018/06/30/portland-planning-board-gets-ball-rolling-on-commercial-street-hotel-condo-project/" onclick="ga('send', 'event', 'click', 'hovernav | realestate', 'Portland Planning Board gets ball rolling on Commercial Street hotel, condo project');">
Portland Planning Board gets ball rolling on Commercial Street hotel, condo project </a>
</div>
<div class="nav-excerpt"></div>
</div>
<div class="more-headlines">
<ul>
<li><h2>More Headlines</h2></li>
<li>
<a href="https://www.centralmaine.com/2018/05/01/ways-to-simplify-diy-projects-home-improvements/" onclick="ga('send', 'event', 'click', 'hovernav | realestate', 'Ways to simplify DIY projects, home improvements');">
Ways to simplify DIY projects, home improvements </a>
</li>
<li>
<a href="https://www.centralmaine.com/2018/04/24/personalized-shed-can-become-your-backyard-oasis/" onclick="ga('send', 'event', 'click', 'hovernav | realestate', 'Personalized shed can become your backyard oasis');">
Personalized shed can become your backyard oasis </a>
</li>
</ul>
</div>
<div class="more-in">
<ul>
<li><h2>More in Real Estate</h2></li>
<li>
<a href="https://www.centralmaine.com/realestate/home-of-the-week/">
Home of the Week </a>
</li>
<li>
<a href="https://www.centralmaine.com/realestate/design/">
Design </a>
</li>
</ul>
</div>
</div>
</li>
<li id="menu-item-977058" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-977058 depth-0"><a target="_blank" href="http://mainejobs.com">MaineJobs</a></li>
<li id="menu-item-724475" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-724475 depth-0"><a target="_blank" href="http://www.mainenotices.com/?utm_source=centralmaine.com&#038;utm_medium=referral&#038;utm_campaign=menu">Public Notices</a></li>
<li id="menu-item-864715" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-864715 depth-0"><a href="https://www.centralmaine.com/auto/">Auto</a>
<div class="hover-navigation auto">
<div class="featured-headline">
<div class="image-crop">
<a href="https://www.centralmaine.com/2018/11/19/on-the-road-review-mitsubishi-eclipse-cross/" onclick="ga('send', 'event', 'click', 'hovernav | auto', 'On the Road Review: Mitsubishi Eclipse Cross');">
<img width="250" height="250" src="https://multifiles.pressherald.com/uploads/sites/2/2018/11/IMG_8841-250x250.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://multifiles.pressherald.com/uploads/sites/2/2018/11/IMG_8841-250x250.jpg 250w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/IMG_8841-32x32.jpg 32w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/IMG_8841-50x50.jpg 50w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/IMG_8841-64x64.jpg 64w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/IMG_8841-96x96.jpg 96w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/IMG_8841-128x128.jpg 128w" sizes="(max-width: 250px) 100vw, 250px" /> </a>
</div>
<div class="category">
Auto </div>
<div class="nav-headline">
<a href="https://www.centralmaine.com/2018/11/19/on-the-road-review-mitsubishi-eclipse-cross/" onclick="ga('send', 'event', 'click', 'hovernav | auto', 'On the Road Review: Mitsubishi Eclipse Cross');">
On the Road Review: Mitsubishi Eclipse Cross </a>
</div>
<div class="nav-excerpt"></div>
</div>
<div class="more-headlines">
<ul>
<li><h2>More Headlines</h2></li>
<li>
<a href="https://www.centralmaine.com/2018/11/16/on-the-road-review-volvo-xc60-t8-plug-in-hybrid/" onclick="ga('send', 'event', 'click', 'hovernav | auto', 'On the Road Review: Volvo XC60 T8 Plug-in Hybrid');">
On the Road Review: Volvo XC60 T8 Plug-in Hybrid </a>
</li>
<li>
<a href="https://www.centralmaine.com/2018/11/14/should-one-tip-a-mobile-mechanic/" onclick="ga('send', 'event', 'click', 'hovernav | auto', 'Should one tip a mobile mechanic?');">
Should one tip a mobile mechanic? </a>
</li>
</ul>
</div>
<div class="more-in">
<ul>
<li><h2>More in Auto</h2></li>
</ul>
</div>
</div>
</li>
</ul>
<div class="search-toggle">
<i class="fa fa-search" aria-hidden="true"></i>
</div>
<a href="/login"><div class="login">Subscriber<br><span>Log in</span></div></a>
<div class="active-user">Welcome <span class="username"></span> <a href="/logout">Log Out</a></div>
<div class="signup"><a href="/subscribe"><span>Subscribe</span></a></div>
<div class="clear">&nbsp;</div>
</div>
<div class="mtm-wrapper post-wrapper">
<div id="pos_1_atf_728x90-wrap" class="ad-wrapper"><div id="pos_1_atf_728x90" class="mtm-leaderboard-pos1"><script type="text/javascript">googletag.cmd.push(function(){googletag.display('pos_1_atf_728x90'); });</script></div></div>
<div class='main-content-wrap'>
<div itemscope itemtype="http://schema.org/Article" class="mtm-article-full-width" id="js-mtm-article">
<header>
<a href="https://www.centralmaine.com/sports/" class="category-wrapper">
<div class="category">
Sports </div>
</a>
<div class="timestamp">
<div class="posted">
Posted <time itemprop="datePublished" datetime="2018-11-19T04:00:00+00:00">4:00 AM</time>
</div>
<div class="updated">
Updated <span><span style="font-weight:normal">at</span> 8:29 AM</span>
</div>
</div>
<div class="font-resize">
<span>increase font size</span>
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/font-resize.png" alt="Resize Font" />
</div>
<h1 itemprop="headline">For Portland High basketball coach Joe Russo, a battle with cancer is providing his biggest win</h1>
<p class="article-excerpt" itemprop="description">
Joe Russo is in remission after treatments for the disease that was diagnosed in February. </p>
</header>
<div class="mtm-article">
<div class="byline">
<div id="mobile_navigation">
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/byline-mobile-nav.png" />
</div>
<div class="byline-author coauthor">
<div class="name">
<span class="by">By </span><a href="//www.pressherald.com" title="Posts by Steve Craig" class="author url fn" rel="author">Steve Craig</a><span class="sourceline">Portland Press Herald</span> </div>
</div>
</div>
<div class="contact">
</div>
<nav role="navigation" id="socialnav">
<ul>
<li><a target='_blank' class='author-meta-twitter' href='http://twitter.com/intent/follow?screen_name=%40SteveCCraig'>Follow on Twitter</a></li><li><a href="/cdn-cgi/l/email-protection#4c3f2f3e2d252b0c3c3e293f3f24293e2d2028622f2321" class='author-meta-email'>Email Writer</a></li><li><a href='tel:207-791-6413' class='author-meta-phone'>207-791-6413</a></li>
</ul>
</nav>
<div class="article-social-sharing">
<div class="share-name">Share</div>
<div class="facebook social-button">
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.centralmaine.com%2F2018%2F11%2F19%2Ffor-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win%2F" target="_blank">
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/article-fb-icon.png" alt="facebook">
</a>
</div>
<div class="twitter social-button">
<a href="https://twitter.com/intent/tweet/?text=For+Portland+High+basketball+coach+Joe+Russo%2C+a+battle+with+cancer+is+providing+his+biggest+win&amp;url=https%3A%2F%2Fwww.centralmaine.com%2F%3Fp%3D1128310" target="_blank">
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/article-twitter-icon.png" alt="tweet">
</a>
</div>
<div class="reddit social-button">
<a href="http://www.reddit.com/submit?title=For+Portland+High+basketball+coach+Joe+Russo%2C+a+battle+with+cancer+is+providing+his+biggest+win&amp;url=https%3A%2F%2Fwww.centralmaine.com%2F%3Fp%3D1128310" target="_blank">
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/reddit-icon.png" alt="reddit">
</a>
</div>
<div class="email social-button">
<a href="http://api.addthis.com/oexchange/0.8/forward/email/offer?title=For+Portland+High+basketball+coach+Joe+Russo%2C+a+battle+with+cancer+is+providing+his+biggest+win&amp;pubid=ra-535983434d690928&amp;url=https%3A%2F%2Fwww.centralmaine.com%2F2018%2F11%2F19%2Ffor-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win%2F" target="_blank">
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/article-email-icon.png" alt="email">
</a>
</div>
<div class="print social-button">
<a href="http://api.addthis.com/oexchange/0.8/forward/printfriendly/offer?title=&amp;pubid=ra-535983434d690928&amp;url=https%3A%2F%2Fwww.centralmaine.com%2F2018%2F11%2F19%2Ffor-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win%2F" target="_blank">
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/article-print-icon.png" alt="print">
</a>
</div>
</div>
<div class="comment-button article-launch" style="display:none;">
<a onclick="ga('send', 'event', 'UI', 'click', 'articlebottom | viewarticle', {'nonInteraction': 1});">
Read Article </a>
</div>
<div class="post-content clearfix" itemprop="articleBody" id="js-post-content" data-truncate="3">
<p>Joe Russo had one worry at his regular doctor visits.</p>
<p>&#8220;Just don&#8217;t say the C-word,&#8221; he said. &#8220;I&#8217;ve always been pretty healthy. I could deal with something like bad cholesterol. Just don&#8217;t say I&#8217;ve got the C-word.&#8221;</p><div class="inner-sidebar">
<div class="article-sidebar">
<div class="article-additional-photos">
<h3></h3>
<div class="photo-scale">
<div class="photo-scale-icon"></div>
<img src="https://multifiles.pressherald.com/uploads/sites/2/2018/11/858254-20181116_Coach926-1024x694.jpg" alt="Portland High School basketball coach Joe Russo in his office. Russo was diagnosed with cancer earlier this year and has been undergoing treatments. " />
<div class="photo-credit">
Portland High School basketball coach Joe Russo in his office. Russo was diagnosed with cancer earlier this year and has been undergoing treatments. <span class="credit">Staff photo by Shawn Patrick Ouellette</span> </div>
</div>
</div>
<div class="photo-store">
<div class="photo-store-icon">
<a href="http://mainetoday.mycapture.com/mycapture/index.asp" target="_blank">
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/photostore-icon.png" alt="photo-store">
</a>
</div>
<div class="description">
Search photos available for purchase: <a href="http://mainetoday.mycapture.com/mycapture/index.asp" target="_blank">Photo Store →</a>
</div>
</div>
</div></div>
<p>In late February, shortly after his 28th season as the Portland High boys&#8217; basketball coach, Russo&#8217;s worst fear was realized. He&#8217;d been experiencing pain in his hip and jaw. Biopsies revealed he had non-Hodgkin Large B Cell Lymphoma.</p>
<p>Cancer.</p>
<p>&#8220;When (the oncologist) said that, to be honest with you I didn&#8217;t hear one word after that. Once she mentioned lymphoma, I didn&#8217;t hear anything she said for that whole meeting until the very end,&#8221; Russo said. &#8220;I was thinking one week, two weeks, what stage?&#8221;</p>
<p>While his wife Donna and son Scott, an ER doctor at Mercy Hospital, asked questions and got details, Russo&#8217;s mind was a blur of what-if scenarios.</p>
<p>Then at the very end of the meeting he heard, &#8220;This type of cancer is treatable and curable.&#8221; The competitive Russo, who had cut his basketball teeth on Munjoy Hill playgrounds, graduated from Portland High and starred at the University of Maine at Presque Isle, was stirred.</p>
<p>&#8220;I said, &#8216;I&#8217;m ready to go. I want the treatment now,&#8217; &#8221; he said.</p>
<p>Russo, 61, would find out beating cancer is possible, especially with support from family and a large group of friends, and being open to using a full range of treatment for both physical and emotional recovery.</p>
<p>Russo was declared in remission in early October. He hopes a PET Scan scheduled for Dec. 3 will provide further confirmation of recovery.</p>
<p>A 2018 inductee to the Maine Basketball Hall of Fame, Russo has won five state championships and 419 games. Practice for the new season starts Monday and Russo will be there, along with his longtime assistants Joe Giordano and Carmine Rumo, and part-time coach Joel Rogers.</p>
<p>That was far from certain when Russo was inducted into the Hall of Fame on Aug. 19. At that time he was in the tail end of chemotherapy and other treatments. At the induction ceremony Russo had lost his hair and 30 pounds. Dark circles rimmed his eyes.</p>
<p>&#8220;Man, I was just a skeleton of myself,&#8221; Russo said. &#8220;Down from 190 pounds to 160. No hair. I can&#8217;t even look at some of the pictures now.&#8221;</p>
<p>Late last week, in his memorabilia-stuffed basement office at Portland High, Joe Russo looked and sounded very much like the man who led the Bulldogs to a 76-8 record with three regional and two state titles over the past four seasons.</p>
<p>His normally thick hair is returning, perhaps a little grayer. Russo said he&#8217;s almost ready to get his first post-chemo haircut. He&#8217;s gained seven pounds back. His gait might be a bit slower ascending the stairs to the school gym, and he&#8217;s not ready to do his regular 50 pushups, &#8220;but now I can do 10.&#8221;</p>
<p>When the school year started, Russo returned to his part-time position as a physical education teacher and girls&#8217; volleyball coach at Portland. Russo and Rumo started the volleyball program a few years ago and the school said they couldn&#8217;t find a replacement coach for this fall, according to Russo. Rumo and parent-volunteer Peter Chadbourne took care of more of the volleyball responsibilities. Doctor&#8217;s visits, scans and fatigue kept Russo from attending some games and practices.</p>
<p>At that time, Giordano and Rumo both said they fully expected Russo to be ready to coach basketball.</p>
<p>Russo, however, wasn&#8217;t so certain.</p>
<p>&#8220;About a month ago I wasn&#8217;t sure I could do it,&#8221; Russo said. &#8220;It was more emotionally. The focus, I wasn&#8217;t sure I could even comprehend the movement because you really couldn&#8217;t concentrate. … I was worried I wouldn&#8217;t be able to explain or comprehend the Xs and Os.&#8221;</p>
<p>Russo&#8217;s current players wondered if they would have their coach back.</p>
<p>&#8220;I was kind of nervous, worried, because I really wanted him to be my coach my senior year and there was just that possibility that he wouldn&#8217;t coach,&#8221; said Portland senior forward Trey Ballew, &#8220;but he kept fighting and he beat it now, so I&#8217;m glad.&#8221;</p>
<p>Now Russo is both excited and a bit anxious about Monday&#8217;s practice. He wasn&#8217;t able to have his normal interaction with players over the summer. He would show up occasionally to summer league games, &#8220;just to visit. So they&#8217;d see me,&#8221; but left the coaching to Giordano and Rumo.</p>
<p>He said Monday he&#8217;ll let the players know he&#8217;s in remission and &#8220;I&#8217;m feeling like it should be OK.&#8221;</p>
<p>As the treatments continued to show signs of recovery, Russo began to worry more about his mental state. He was finding it difficult to focus on tasks. &#8220;They call it a chemo fog,&#8221; he said.</p>
<p>Worse, Russo recognized he was increasingly caught in a lethargic, apathetic mood. &#8220;Emotionally detached,&#8221; he described it. Visiting friends and family, having breakfast with buddies, traveling to a Boston Celtics game, weren&#8217;t worth the energy.</p>
<p>&#8220;It was kind of scary to me when I was detached emotionally and things didn&#8217;t mean as much. I was scared I wasn&#8217;t going to get that back,&#8221; Russo said.</p>
<p>Even after he had gotten the official medical word that he was in remission, Russo&#8217;s mental state didn&#8217;t improve immediately.</p>
<p>Through sessions with counselors and attending lymphoma support groups at The Dempsey Center in South Portland, Russo learned his feelings were not uncommon.</p>
<p>&#8220;I asked, &#8216;I&#8217;m in remission, I should be the happiest guy in the world, why am I not acting like it?&#8217; They said it was like post-traumatic, now you&#8217;re realizing what you went through and what you were facing,&#8221; Russo said.</p>
<p>He went to meditation classes and used acupuncture to help deal with stress. He spoke to priests and relied on his faith for spiritual healing.</p>
<p>&#8220;Now with that training and support I&#8217;m feeling good. And what a relief,&#8221; Russo said.</p>
<p>Throughout the process Russo always recognized the support he was receiving, from family, friends, fellow coaches and former players.</p>
<p>&#8220;It was so much support I couldn&#8217;t let myself go crawl in a corner. I think I would let too many people down,&#8221; Russo said. &#8220;I would have let a lot of people down, too, if I hadn&#8217;t put up a fight. Plus I know I&#8217;m not going to live forever, but I want a few more years with my kids and (nine) grandkids.&#8221;</p>
<p>Recently, Russo has begun enjoying the little things. He had breakfast with his old fraternity brothers for the first time after he &#8220;blew them off for awhile because I just wasn&#8217;t there.&#8221;</p>
<p>Two Sundays ago, the Russo clan gathered at Joe and Donna&#8217;s house for dinner.</p>
<p>&#8220;We had pasta, everybody came over, the first time I cooked sauce since February,&#8221; he said.</p>
<p>Russo said there were many times over the past nine months when he had to do some self-coaching, to think, what would I say to one of my players having a tough time? He would remind himself to have a positive mindset, to keep working at recovery, &#8220;to fight it,&#8221; and to take a moment to appreciate the thousands of texts and emails offering support and prayers.</p>
<p>Now Russo is in the position to return to coaching – and to help others.</p>
<p>&#8220;What I would tell people is: You can&#8217;t do it alone. And I had no problem reaching out for support. Anyone going through it shouldn&#8217;t be ashamed of seeking help.&#8221;</p>
<p><em>Steve Craig can be reached at 791-6413 or:</em></p>
<p><em><a target="_blank" rel="noopener"><span class="__cf_email__" data-cfemail="0a7969786b636d4a">[email&#160;protected]</span>pressherald.com</a></em></p>
<p><a target="_blank" rel="noopener">Twitter: SteveCCraig</a></p>
<div class="mobile-article-sidebar-wrapper">
<div class="mobile-article-sidebar-1"></div>
<div class="mobile-article-sidebar-2"></div>
</div>
<div class="article-social-sharing bottom no-print">
<div class="share-name">Share</div>
<div class="facebook social-button">
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.centralmaine.com%2F2018%2F11%2F19%2Ffor-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win%2F" target="_blank">
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/article-fb-icon.png" alt="facebook">
</a>
</div>
<div class="twitter social-button">
<a href="https://twitter.com/intent/tweet/?text=For+Portland+High+basketball+coach+Joe+Russo%2C+a+battle+with+cancer+is+providing+his+biggest+win&amp;url=https%3A%2F%2Fwww.centralmaine.com%2F%3Fp%3D1128310" target="_blank">
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/article-twitter-icon.png" alt="tweet">
</a>
</div>
<div class="reddit social-button">
<a href="http://www.reddit.com/submit?title=For+Portland+High+basketball+coach+Joe+Russo%2C+a+battle+with+cancer+is+providing+his+biggest+win&amp;url=https%3A%2F%2Fwww.centralmaine.com%2F%3Fp%3D1128310" target="_blank">
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/reddit-icon.png" alt="reddit">
</a>
</div>
<div class="email social-button">
<a href="http://api.addthis.com/oexchange/0.8/forward/email/offer?title=For+Portland+High+basketball+coach+Joe+Russo%2C+a+battle+with+cancer+is+providing+his+biggest+win&amp;pubid=ra-535983434d690928&amp;url=https%3A%2F%2Fwww.centralmaine.com%2F2018%2F11%2F19%2Ffor-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win%2F" target="_blank">
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/article-email-icon.png" alt="email">
</a>
</div>
<div class="print social-button">
<a href="http://api.addthis.com/oexchange/0.8/forward/printfriendly/offer?title=&amp;pubid=ra-535983434d690928&amp;url=https%3A%2F%2Fwww.centralmaine.com%2F2018%2F11%2F19%2Ffor-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win%2F" target="_blank">
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/article-print-icon.png" alt="print">
</a>
</div> </div>
<div class="comment-button comment-launch no-print">
<a onclick="ga('send', 'event', 'UI', 'click', 'articlebottom | viewcomments', {'nonInteraction': 1});" class="disqus-comment-count" data-disqus-url="https://www.centralmaine.com/2018/11/19/for-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win/"><i class="fa fa-comment"></i> Read or Post Comments</a>
</div>
<div class="feedback clearfix no-print">
<p>
<a href="/feedback-form/">
Send questions/comments to the editors. </a>
</p>
</div>
<p class="article-prev-btn"><a href="https://www.centralmaine.com/2018/11/18/john-ford-sr-former-maine-game-warden-sheriff-author-dies-at-71/" rel="prev">&lt; Previous</a></p>
<div class="previous-article">
<a href="https://www.centralmaine.com/2018/11/18/joey-logano-captures-nascar-series-cup-title/" rel="prev">Joey Logano captures NASCAR Series Cup title</a> </div>
<p class="article-next-btn"><a href="https://www.centralmaine.com/2018/11/19/on-the-road-review-mitsubishi-eclipse-cross/" rel="next">Next &gt;</a></p>
<div class="next-article">
</div>
<div class="clearfix"></div>


<div id='native_ad' class='no-print'>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>
							googletag.cmd.push(function() { googletag.display('native_ad'); });
						</script>
</div>

<div class="art-bottom-links no-print">
<div class="art-bottom-title">Related Stories</div>
<div class="mtm-related-posts" id="js-mtm-related-posts" data-post-id="1128310">

<div class="ajax-loader">
<img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/ajax-loader.gif" alt="Loading Related Posts">
</div>
</div>
</div>
<div class="art-bottom-links last-col no-print">
<div class="art-bottom-title">Latest Articles</div>
<ul> <li>
<div class="image-crop">
<a href="https://www.centralmaine.com/2018/11/19/sisters-taking-up-indian-mascot-issue-with-skowhegan-school-board/">
<img width="250" height="250" src="https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128906_576759-20181119-indian-1-250x250.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128906_576759-20181119-indian-1-250x250.jpg 250w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128906_576759-20181119-indian-1-32x32.jpg 32w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128906_576759-20181119-indian-1-50x50.jpg 50w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128906_576759-20181119-indian-1-64x64.jpg 64w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128906_576759-20181119-indian-1-96x96.jpg 96w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128906_576759-20181119-indian-1-128x128.jpg 128w" sizes="(max-width: 250px) 100vw, 250px" /> </a>
</div>
<div class="category">Schools and Education</div>
<h2>
<a href="https://www.centralmaine.com/2018/11/19/sisters-taking-up-indian-mascot-issue-with-skowhegan-school-board/">Sisters taking up Indian mascot issue with Skowhegan school board</a>
</h2>
</li>
<li>
<div class="image-crop">
<a href="https://www.centralmaine.com/2018/11/19/bronx-ny-man-arrested-in-nh-on-augusta-drug-charges/">
<img width="250" height="250" src="https://multifiles.pressherald.com/uploads/sites/2/2018/11/walker-250x250.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://multifiles.pressherald.com/uploads/sites/2/2018/11/walker-250x250.jpg 250w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/walker-32x32.jpg 32w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/walker-50x50.jpg 50w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/walker-64x64.jpg 64w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/walker-96x96.jpg 96w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/walker-128x128.jpg 128w" sizes="(max-width: 250px) 100vw, 250px" /> </a>
</div>
<div class="category">Maine Crime</div>
<h2>
<a href="https://www.centralmaine.com/2018/11/19/bronx-ny-man-arrested-in-nh-on-augusta-drug-charges/">Bronx, NY, man arrested in NH on Augusta drug charges</a>
</h2>
</li>
<li>
<div class="image-crop">
<a href="https://www.centralmaine.com/2018/11/19/university-of-maine-starts-on-search-for-umf-president/">
<img width="250" height="250" src="https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128846_912970_20181102_question_4_-250x250.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128846_912970_20181102_question_4_-250x250.jpg 250w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128846_912970_20181102_question_4_-32x32.jpg 32w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128846_912970_20181102_question_4_-50x50.jpg 50w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128846_912970_20181102_question_4_-64x64.jpg 64w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128846_912970_20181102_question_4_-96x96.jpg 96w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1128846_912970_20181102_question_4_-128x128.jpg 128w" sizes="(max-width: 250px) 100vw, 250px" /> </a>
</div>
<div class="category">Schools and Education</div>
<h2>
<a href="https://www.centralmaine.com/2018/11/19/university-of-maine-starts-on-search-for-umf-president/">University of Maine System starts search for UMF president</a>
</h2>
</li>
<li>
<div class="category">Maine Crime</div>
<h2>
<a href="https://www.centralmaine.com/2018/11/19/morning-sentinel-nov-19-police-log-5/">Morning Sentinel Nov. 19 police log</a>
</h2>
</li>
<li>
<div class="image-crop">
<a href="https://www.centralmaine.com/2018/11/19/davids-bridal-files-for-bankruptcy-tries-to-reassure-brides-to-be/">
<img width="250" height="250" src="https://multifiles.pressherald.com/uploads/sites/2/2018/11/1680798_Davids_Bridal_Bankruptcy_10-250x250.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://multifiles.pressherald.com/uploads/sites/2/2018/11/1680798_Davids_Bridal_Bankruptcy_10-250x250.jpg 250w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1680798_Davids_Bridal_Bankruptcy_10-32x32.jpg 32w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1680798_Davids_Bridal_Bankruptcy_10-50x50.jpg 50w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1680798_Davids_Bridal_Bankruptcy_10-64x64.jpg 64w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1680798_Davids_Bridal_Bankruptcy_10-96x96.jpg 96w, https://multifiles.pressherald.com/uploads/sites/2/2018/11/1680798_Davids_Bridal_Bankruptcy_10-128x128.jpg 128w" sizes="(max-width: 250px) 100vw, 250px" /> </a>
</div>
<div class="category">Nation &amp; World</div>
<h2>
<a href="https://www.centralmaine.com/2018/11/19/davids-bridal-files-for-bankruptcy-tries-to-reassure-brides-to-be/">David&#8217;s Bridal files for bankruptcy, tries to reassure brides-to-be</a>
</h2>
</li>
</ul> </div>
<div class='no-print'>
<div class='gf_browser_unknown gform_wrapper' id='gform_wrapper_82'><a id='gf_82' class='gform_anchor'></a><form method='post' enctype='multipart/form-data' target='gform_ajax_frame_82' id='gform_82' action='/2018/11/19/for-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win/#gf_82'>
<div class='gform_heading'>
<h3 class='gform_title'>Augusta and Waterville news</h3>
<span class='gform_description'>Get news and events from your towns in your inbox every Friday.</span>
</div>
<div class='gform_body'><ul id='gform_fields_82' class='gform_fields top_label form_sublabel_below description_below'><li id='field_82_3' class='gfield gfield_html gfield_html_formatted gfield_no_follows_desc field_sublabel_below field_description_below gfield_visibility_visible'><hr class="cta-line">
<div class="subscribe-cta">
<div class="sub-cta-headline">Augusta &amp; Waterville news</div>
<div class="sub-cta-body">Get news and events from your towns in your inbox every Friday.</div>
</div></li><li id='field_82_1' class='gfield gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible'><label class='gfield_label' for='input_82_1'>Enter your email address<span class='gfield_required'>*</span></label><div class='ginput_container ginput_container_email'>
<input name='input_1' id='input_82_1' type='text' value='' class='large' tabindex='1' aria-required="true" aria-invalid="false" />
</div></li><li id='field_82_2' class='gfield field_sublabel_below field_description_below gfield_visibility_visible'><label class='gfield_label'>Select your news:</label><div class='ginput_container ginput_container_checkbox'><ul class='gfield_checkbox' id='input_82_2'><li class='gchoice_82_2_1'>
<input name='input_2.1' type='checkbox' value='Augusta area news' id='choice_82_2_1' tabindex='2' />
<label for='choice_82_2_1' id='label_82_2_1'>Augusta area news</label>
</li><li class='gchoice_82_2_2'>
<input name='input_2.2' type='checkbox' value='Waterville area news' id='choice_82_2_2' tabindex='3' />
<label for='choice_82_2_2' id='label_82_2_2'>Waterville area news</label>
</li></ul></div></li><li id='field_82_4' class='gfield gfield_html gfield_html_formatted gfield_no_follows_desc field_sublabel_below field_description_below gfield_visibility_visible'><hr class="cta-line">
<style>
.cta-line {
    border: 1px solid #ccc;
    clear: both;
}
.sub-cta-headline {
    font-family: "Lusitana", serif;
    font-size: 20px;
    color: #c62828;
}
.subscribe-cta {
    width: 100%;
    padding: 10px;
}
#gform_submit_button_82 {
    background-color: #c62828;
    color: #fff;
    display: inline-block;
    position: relative;
    top: -78px;
    right: -70%;
    border: none;
    padding: 3px 10px;
    box-shadow: none !important;
    max-width: 30%;
}
#gform_wrapper_82 .gform_heading {
    display: none;
}

#field_82_2 {
     padding:12px;
}
#gform_wrapper_82 .gform_wrapper input:not([type=radio]):not([type=checkbox]):not([type=submit]):not([type=button]):not([type=image]):not([type=file]) {
      border: 1px solid #ccc;
}
body .gform_wrapper ul li.gfield {
    margin-top: 0px !important;
}
</style></li><li id='field_82_5' class='gfield gform_validation_container field_sublabel_below field_description_below gfield_visibility_visible'><label class='gfield_label' for='input_82_5'>Name</label><div class='ginput_container'><input name='input_5' id='input_82_5' type='text' value='' /></div><div class='gfield_description'>This field is for validation purposes and should be left unchanged.</div></li>
</ul></div>
<div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_82' class='gform_button button' value='Submit' tabindex='4' onclick='if(window["gf_submitting_82"]){return false;}  window["gf_submitting_82"]=true;  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_82"]){return false;} window["gf_submitting_82"]=true;  jQuery("#gform_82").trigger("submit",[true]); }' /> <input type='hidden' name='gform_ajax' value='form_id=82&amp;title=1&amp;description=1&amp;tabindex=1' />
<input type='hidden' class='gform_hidden' name='is_submit_82' value='1' />
<input type='hidden' class='gform_hidden' name='gform_submit' value='82' />
<input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
<input type='hidden' class='gform_hidden' name='state_82' value='WyJbXSIsIjljZDljOTdiMWYwNDE1YjFjYTk1Y2UxOWM4NDk4MGUzIl0=' />
<input type='hidden' class='gform_hidden' name='gform_target_page_number_82' id='gform_target_page_number_82' value='0' />
<input type='hidden' class='gform_hidden' name='gform_source_page_number_82' id='gform_source_page_number_82' value='1' />
<input type='hidden' name='gform_field_values' value='' />
</div>
</form>
</div>
<iframe style='display:none;width:0px;height:0px;' src='about:blank' name='gform_ajax_frame_82' id='gform_ajax_frame_82'>This iframe contains the logic required to handle Ajax powered Gravity Forms.</iframe>
<script type='text/javascript'>jQuery(document).ready(function($){gformInitSpinner( 82, 'https://www.centralmaine.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery('#gform_ajax_frame_82').load( function(){var contents = jQuery(this).contents().find('*').html();var is_postback = contents.indexOf('GF_AJAX_POSTBACK') >= 0;if(!is_postback){return;}var form_content = jQuery(this).contents().find('#gform_wrapper_82');var is_confirmation = jQuery(this).contents().find('#gform_confirmation_wrapper_82').length > 0;var is_redirect = contents.indexOf('gformRedirect(){') >= 0;var is_form = form_content.length > 0 && ! is_redirect && ! is_confirmation;if(is_form){jQuery('#gform_wrapper_82').html(form_content.html());if(form_content.hasClass('gform_validation_error')){jQuery('#gform_wrapper_82').addClass('gform_validation_error');} else {jQuery('#gform_wrapper_82').removeClass('gform_validation_error');}setTimeout( function() { /* delay the scroll by 50 milliseconds to fix a bug in chrome */ jQuery(document).scrollTop(jQuery('#gform_wrapper_82').offset().top); }, 50 );if(window['gformInitDatepicker']) {gformInitDatepicker();}if(window['gformInitPriceFields']) {gformInitPriceFields();}var current_page = jQuery('#gform_source_page_number_82').val();gformInitSpinner( 82, 'https://www.centralmaine.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery(document).trigger('gform_page_loaded', [82, current_page]);window['gf_submitting_82'] = false;}else if(!is_redirect){var confirmation_content = jQuery(this).contents().find('.GF_AJAX_POSTBACK').html();if(!confirmation_content){confirmation_content = contents;}setTimeout(function(){jQuery('#gform_wrapper_82').replaceWith(confirmation_content);jQuery(document).scrollTop(jQuery('#gf_82').offset().top);jQuery(document).trigger('gform_confirmation_loaded', [82]);window['gf_submitting_82'] = false;}, 50);}else{jQuery('#gform_82').append(contents);if(window['gformRedirect']) {gformRedirect();}}jQuery(document).trigger('gform_post_render', [82, current_page]);} );} );</script><script type='text/javascript'> if(typeof gf_global == 'undefined') var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2},"base_url":"https:\/\/www.centralmaine.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"https:\/\/www.centralmaine.com\/wp-content\/plugins\/gravityforms\/images\/spinner.gif"};jQuery(document).bind('gform_post_render', function(event, formId, currentPage){if(formId == 82) {} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} );</script><script type='text/javascript'> jQuery(document).ready(function(){jQuery(document).trigger('gform_post_render', [82, 1]) } ); </script> </div>
</div> 
<div class="mtm-article-comments">
<p>Here at <strong>MaineToday Media</strong> we value our readers and are committed to growing our community by encouraging you to add to the discussion. </p>
<p>To ensure conscientious dialogue we have implemented a strict no-bullying policy. To participate, you must follow our <a target="_blank" href="/terms-use/">Terms of Use</a>. <a target="_blank" href="/feedback/">Click here</a> to flag and report a comment that violates our terms of use.</p>
<div id="disqus_thread"></div>
</div>
</div> 
<div class="mtm-ad-col-article" id="js-mtm-sidebar">
<ul class="widget-sidebar">
<li id="custom_html-14" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="browse-title">Browse more in Sports</div>
<div class="browse-container">
<ul><li><a href="/sports/highschoolsports/">High school sports</a></li>
<li><a href="/sports/college/">College sports</a></li>
<li><a href="/sports/outdoors/">Outdoors</a></li>
</ul></div>
<div class="browse-container">
<ul>
<li><a href="/redsox/">Boston Red Sox</a></li>
<li><a href="/patriots/">New England Patriots</a></li>
</ul>
</div>
<div class="clearfix" style="margin-bottom:45px;"></div>
<style>
.browse-title {
    font-family: 'Open Sans', sans-serif;
    font-weight: bold;
    font-size: 14px;
    text-transform: uppercase;
    color: #222;
    background-color: #e6e6e6;
    border-left: 4px solid #c62828;
    padding:6px 10px;
    text-align: left;
    margin-bottom: 15px;
    width:90%;
}
.browse-container {
    width: 45%;
    padding-right: 15px;
    float:left;
    display: inline;
    text-align:left;
}
.browse-container li {
    list-style: none !important;
    margin-bottom: 8px;
    line-height: 15px;
}
.browse-container li a {
    clear: both;
    font-size: 13px;
    color: #333;
    font-family: 'Open Sans', sans-serif;
    text-transform: uppercase;
    margin-bottom: 12px;
    text-decoration: none;
}
.browse-container li a:hover {
    text-decoration: underline;
}
.browse-links br {
    margin-bottom:12px;
}
</style></div></li>
<li id="acm_ad_zones-4" class="widget acm_ad_zones"><div id="pos_2_atf_300x250-wrap" class="ad-wrapper"><div id="pos_2_atf_300x250" class="pos_2_atf_300x250"><script type="text/javascript">googletag.cmd.push(function(){googletag.display('pos_2_atf_300x250'); });</script></div></div></li>
<li id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="vm-logo"><img src="https://multifiles.pressherald.com/uploads/sites/2/2018/02/email-signup-logos.png" /></div>
<div class='gf_browser_unknown gform_wrapper article-signup_wrapper' id='gform_wrapper_33'><a id='gf_33' class='gform_anchor'></a><form method='post' enctype='multipart/form-data' target='gform_ajax_frame_33' id='gform_33' class='article-signup' action='/2018/11/19/for-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win/#gf_33'>
<div class='gform_heading'>
<h3 class='gform_title'><span>High School Sports</span></h3>
<span class='gform_description'>Receive high schools sports news in your inbox from preseason to the state championship games by entering your email address below.</span>
</div>
<div class='gform_body'><ul id='gform_fields_33' class='gform_fields top_label form_sublabel_below description_below'><li id='field_33_1' class='gfield gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible'><label class='gfield_label' for='input_33_1'>Email<span class='gfield_required'>*</span></label><div class='ginput_container ginput_container_email'>
<input name='input_1' id='input_33_1' type='text' value='' class='large' tabindex='1' aria-required="true" aria-invalid="false" />
</div></li><li id='field_33_3' class='gfield field_sublabel_below field_description_below gfield_visibility_visible'><label class='gfield_label'></label><div class='ginput_container ginput_container_checkbox'><ul class='gfield_checkbox' id='input_33_3'><li class='gchoice_33_3_1'>
<input name='input_3.1' type='checkbox' value='I understand the &lt;a href=&quot;http://www.centralmaine.com/terms-service/&quot; target=&quot;_blank&quot;&gt;Terms of Service. &lt;/a&gt;' checked='checked' id='choice_33_3_1' tabindex='2' />
<label for='choice_33_3_1' id='label_33_3_1'>I understand the <a href="http://www.centralmaine.com/terms-service/" target="_blank">Terms of Service. </a></label>
</li></ul></div></li>
</ul></div>
<div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_33' class='gform_button button' value='Sign up' tabindex='3' onclick='if(window["gf_submitting_33"]){return false;}  window["gf_submitting_33"]=true;  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_33"]){return false;} window["gf_submitting_33"]=true;  jQuery("#gform_33").trigger("submit",[true]); }' /> <input type='hidden' name='gform_ajax' value='form_id=33&amp;title=1&amp;description=1&amp;tabindex=1' />
<input type='hidden' class='gform_hidden' name='is_submit_33' value='1' />
<input type='hidden' class='gform_hidden' name='gform_submit' value='33' />
<input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
<input type='hidden' class='gform_hidden' name='state_33' value='WyJbXSIsIjljZDljOTdiMWYwNDE1YjFjYTk1Y2UxOWM4NDk4MGUzIl0=' />
<input type='hidden' class='gform_hidden' name='gform_target_page_number_33' id='gform_target_page_number_33' value='0' />
<input type='hidden' class='gform_hidden' name='gform_source_page_number_33' id='gform_source_page_number_33' value='1' />
<input type='hidden' name='gform_field_values' value='' />
</div>
</form>
</div>
<iframe style='display:none;width:0px;height:0px;' src='about:blank' name='gform_ajax_frame_33' id='gform_ajax_frame_33'>This iframe contains the logic required to handle Ajax powered Gravity Forms.</iframe>
<script type='text/javascript'>jQuery(document).ready(function($){gformInitSpinner( 33, 'https://www.centralmaine.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery('#gform_ajax_frame_33').load( function(){var contents = jQuery(this).contents().find('*').html();var is_postback = contents.indexOf('GF_AJAX_POSTBACK') >= 0;if(!is_postback){return;}var form_content = jQuery(this).contents().find('#gform_wrapper_33');var is_confirmation = jQuery(this).contents().find('#gform_confirmation_wrapper_33').length > 0;var is_redirect = contents.indexOf('gformRedirect(){') >= 0;var is_form = form_content.length > 0 && ! is_redirect && ! is_confirmation;if(is_form){jQuery('#gform_wrapper_33').html(form_content.html());if(form_content.hasClass('gform_validation_error')){jQuery('#gform_wrapper_33').addClass('gform_validation_error');} else {jQuery('#gform_wrapper_33').removeClass('gform_validation_error');}setTimeout( function() { /* delay the scroll by 50 milliseconds to fix a bug in chrome */ jQuery(document).scrollTop(jQuery('#gform_wrapper_33').offset().top); }, 50 );if(window['gformInitDatepicker']) {gformInitDatepicker();}if(window['gformInitPriceFields']) {gformInitPriceFields();}var current_page = jQuery('#gform_source_page_number_33').val();gformInitSpinner( 33, 'https://www.centralmaine.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery(document).trigger('gform_page_loaded', [33, current_page]);window['gf_submitting_33'] = false;}else if(!is_redirect){var confirmation_content = jQuery(this).contents().find('.GF_AJAX_POSTBACK').html();if(!confirmation_content){confirmation_content = contents;}setTimeout(function(){jQuery('#gform_wrapper_33').replaceWith(confirmation_content);jQuery(document).scrollTop(jQuery('#gf_33').offset().top);jQuery(document).trigger('gform_confirmation_loaded', [33]);window['gf_submitting_33'] = false;}, 50);}else{jQuery('#gform_33').append(contents);if(window['gformRedirect']) {gformRedirect();}}jQuery(document).trigger('gform_post_render', [33, current_page]);} );} );</script><script type='text/javascript'> if(typeof gf_global == 'undefined') var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2},"base_url":"https:\/\/www.centralmaine.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"https:\/\/www.centralmaine.com\/wp-content\/plugins\/gravityforms\/images\/spinner.gif"};jQuery(document).bind('gform_post_render', function(event, formId, currentPage){if(formId == 33) {} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} );</script><script type='text/javascript'> jQuery(document).ready(function(){jQuery(document).trigger('gform_post_render', [33, 1]) } ); </script>
<style>
.widget-sidebar .gform_title {
     display:none;
}
.vm-logo {
    background-color: #ededed;
    text-align: center;
    width: 97%;
    margin-left: 5px;
    padding-top: 2px;
	  margin-bottom:-13px;
}
.widget-sidebar .article-signup {
	background-image:url('https://www.pressherald.com/wp-content/uploads/2015/01/sportsnewsletter-6.png');
	background-color:#fff;
	border:0px;
	padding-left:3%;
	box-shadow:0px 0px 0px #000 inset;
	padding-right:3%;
	padding-top:2%;
	padding-bottom:4.5%;
	width:97%;
	font-family:Helvetica neue, sans-serif;
	text-align:center !important;
	margin-top:14px;
	margin-bottom:14px;
	color:#fff !important;
}

.widget-sidebar .article-signup .button {
	display:inline-block;
	margin-top:10px;
	padding:8px 22px;
	text-decoration:none;
	border:2px solid #008dde;
	background-color:#008dde;
	font-size:12px !important;
	font-weight:400;
	color:#fff;
	text-transform:uppercase;
	letter-spacing:3px;
	-webkit-transition-duration: .25s;
	transition-duration: .25s;
	cursor:pointer;
}

.widget-sidebar .article-signup .button:hover {
	background-color:#fff;
	color:#008dde;
	-webkit-transition-duration: .25s;
	transition-duration: .25s;
}

 .widget-sidebar .article-signup #field_33_1 .gfield_label,  .article-signup #field_33_3 .gfield_label {
	display:none !important;
}

.widget-sidebar .article-signup .email-field input {
	border:0px solid #ccc;
	padding:10px 35px;
	font-family:Georgia, "Times New Roman", Times, serif;
	font-size:16px;
	width:80%;
	margin:0 auto;
	color:#333;
	letter-spacing:.3px;
	font-style:italic;
}

input#input_33_1 {
	padding-top:14px;
	padding-bottom:14px;
	border:0px;
	width:96%;
	margin:0 auto;
}

label#label_3_1 {
	font-size:12px;
}

#gform_wrapper_33{margin-top:0px;}
.article-signup .email-field input:focus {
	background-color:#CEE1EA;	
}

.widget-sidebar .article-signup .gform_footer.top_label {
	padding:0px !important;
	margin:0px !important;
}

.widget-sidebar .gform_wrapper h3.gform_title span {
	text-transform:uppercase;
	font-size:14px;
	letter-spacing:1px;
	font-weight:200;
	display:block;
	margin-top:18px;
}

.widget-sidebar .article-signup h3.gform_title, .article-signup h2.gform_title {
	font-size:32px !important;
	margin-bottom:4px;
	margin-top:12px;
	color:#fff;
	text-align:center;
	text-shadow:0px 0px 10px #000;
}

li#field_33_2 {
	text-align:left;
}

.widget-sidebar .gform_wrapper .gfield_checkbox li label, .widget-sidebar .gform_wrapper .gfield_radio li label {
	font-size:13px;
	text-shadow:0px 0px 2px #000;
}

.widget-sidebar .article-signup .gform_description {
	font-size:14px;
	letter-spacing:.3px;
	color:#fff;
	text-align:center;
	text-shadow:0px 0px 10px #000;
}

.widget-sidebar .gform_wrapper ul.gfield_checkbox li, .widget-sidebar .gform_wrapper ul.gfield_radio li {
	margin-right:4%;
	font-size:14px;
	font-weight:400;
	text-transform:uppercase;
}

.gform_wrapper ul.gfield_checkbox, .gform_wrapper ul.gfield_radio {
	margin-top:14px !important;
}

.widget-sidebar .gform_wrapper ul.gfield_checkbox a {
	color:#27aae1;
}
#field_33_2{
display:none;
}

</style>
<script>
jQuery("#input_33_1").focus(function(){
jQuery("#field_33_2").show();
});
</script></div></li>
<li id="acm_ad_zones-15" class="widget acm_ad_zones"><div id="pos_3_btf_300x250_300x600-wrap" class="ad-wrapper"><div id="pos_3_btf_300x250_300x600"><script type="text/javascript">googletag.cmd.push(function(){googletag.display('pos_3_btf_300x250_300x600'); });</script></div></div></li>
<li id="acm_ad_zones-42" class="widget acm_ad_zones"><div id="pos_btf_8_300x250-wrap" class="ad-wrapper"><div id="pos_btf_8_300x250"><script type="text/javascript">googletag.cmd.push(function(){googletag.display('pos_btf_8_300x250'); });</script></div></div></li>
<li id="custom_html-29" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="ap_widget_container_4b3f3b6666755b7fc57e6cf798bfb3f5"></div>
<script src="https://digitalservices.ap.org/widget-content/4b3f3b6666755b7fc57e6cf798bfb3f5"></script> </div></li>
</ul>
</div>
</div> 
</div> 
</div> 
<div class="mtm-footer active-widgets">
<div id="pos_btf_728x90-wrap" class="ad-wrapper"><div id="pos_btf_728x90" class="BannerAd"><script type="text/javascript">googletag.cmd.push(function(){googletag.display('pos_btf_728x90'); });</script></div></div> <div class="mtm-footer-inner">
<div class="TopPart">
<div class="footer-logo">
<img src="https://multifiles.pressherald.com/uploads/sites/2/2017/06/cm-logo.png" width="225" height="40" alt="Kennebec Journal and Morning Sentinel" />
</div>
<div class="footer-logo-white">
<div class="mtm-mobile-footer-menu"></div>
<img src="https://www.centralmaine.com/wp-content/uploads/sites/2/2014/06/cm-white-footer-nes.png" alt="Kennebec Journal and Morning Sentinel" />
</div>
<div class="mtm-footer-social__links">
<div class="social">
<span class="kj">Kennebec Journal</span>
<span class="kj mobile">KJ</span>
<a href="https://www.facebook.com/CMKennebecJournal/" target="_blank"><img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/fb-reverse.png" alt="facebook" /></a>
<a href="https://twitter.com/KJ_Online" target="_blank"><img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/tw-reverse.png" alt="twitter" /></a>
<a href="http://www.youtube.com/channel/UC0sPBv78fAj46b_AaU159qQ" target="_blank"><img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/youtube-reverse.png" alt="youtube" /></a>
<span class="ms">Morning Sentinel</span>
<span class="ms mobile">MS</span>
<a href="https://www.facebook.com/CMMorningSentinel/" target="_blank"><img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/fb-reverse.png" alt="facebook" /></a>
<a href="https://twitter.com/OnlineSentinel" target="_blank"><img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/tw-reverse.png" alt="twitter" /></a>
<a href="http://www.youtube.com/channel/UC0sPBv78fAj46b_AaU159qQ" target="_blank"><img src="https://www.centralmaine.com/wp-content/themes/mainetoday/assets/images/youtube-reverse.png" alt="youtube" /></a>
</div>
</div>
</div>
<div class="footer-widgets clearfix">
<div id="nav_menu-2" class="widget widget_nav_menu"><h2 class="widgettitle">Contact Us</h2>
<div class="menu-contact-us-container"><ul id="menu-contact-us" class="menu"><li id="menu-item-735263" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-735263 depth-0"><a title="Staff Directory" href="https://www.centralmaine.com/contact/">Contact</a></li>
<li id="menu-item-735264" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-735264 depth-0"><a href="https://www.centralmaine.com/letters-editor/">Submit a Letter to the Editor</a></li>
<li id="menu-item-735265" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-735265 depth-0"><a title="Send a Story Tip" href="https://www.centralmaine.com/news-tip/">News tip</a></li>
<li id="menu-item-735266" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-735266 depth-0"><a href="https://www.centralmaine.com/support/faqs/">FAQs</a></li>
<li id="menu-item-735267" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-735267 depth-0"><a href="https://www.centralmaine.com/site-feedback/">Site Feedback</a></li>
<li id="menu-item-735411" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-735411 depth-0"><a href="https://www.centralmaine.com/career-opportunities/">Work Here</a></li>
</ul></div></div><div id="nav_menu-3" class="widget widget_nav_menu"><h2 class="widgettitle">Subscribers</h2>
<div class="menu-subscription-container"><ul id="menu-subscription" class="menu"><li id="menu-item-449884" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-449884 depth-0"><a href="http://centralmaine.com/order/?ref=paywall-topright&#038;return=https://www.centralmaine.com/?p=332125&#038;promo=extra1">Subscribe</a></li>
<li id="menu-item-449885" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-449885 depth-0"><a href="https://www.centralmaine.com/e-edition/">Access e-Editions</a></li>
<li id="menu-item-735270" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-735270 depth-0"><a href="https://www.centralmaine.com/reader-services/home-delivery-help/">Home Delivery Help</a></li>
<li id="menu-item-735271" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-735271 depth-0"><a href="https://cmniservices.newscyclecloud.com/cmo_lsj-c-cmdb-mtm-01/subscriber/web/signin.html">Manage myAccount</a></li>
<li id="menu-item-735272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-735272 depth-0"><a href="https://myaccount.onlinesentinel.com/payments/">Pay my Bill</a></li>
<li id="menu-item-735273" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-735273 depth-0"><a href="https://www.centralmaine.com/mobile-products/">Mobile Apps</a></li>
</ul></div></div><div id="nav_menu-4" class="widget widget_nav_menu"><h2 class="widgettitle">Connect with Us</h2>
<div class="menu-connect-container"><ul id="menu-connect" class="menu"><li id="menu-item-449886" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-449886 depth-0"><a href="https://www.centralmaine.com/newsletters/">Email Newsletters</a></li>
<li id="menu-item-735276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-735276 depth-0"><a target="_blank" href="https://www.facebook.com/MorningSentinelKennebecJournal">Facebook</a></li>
<li id="menu-item-735278" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-735278 depth-0"><a target="_blank" href="https://twitter.com/KJ_Online">Kennebec Journal Twitter</a></li>
<li id="menu-item-735279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-735279 depth-0"><a target="_blank" href="https://twitter.com/OnlineSentinel">Morning Sentinel Twitter</a></li>
</ul></div></div><div id="nav_menu-5" class="widget widget_nav_menu"><h2 class="widgettitle">Advertise</h2>
<div class="menu-advertise-container"><ul id="menu-advertise" class="menu"><li id="menu-item-746577" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-746577 depth-0"><a href="http://mediakit.pressherald.com/">Media Kit</a></li>
<li id="menu-item-449888" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-449888 depth-0"><a href="https://www.centralmaine.com/advertising">Contact Advertising</a></li>
<li id="menu-item-735297" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-735297 depth-0"><a href="https://www.pressherald.com/jobs-advertising-packages/">Help Wanted Ads</a></li>
<li id="menu-item-735299" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-735299 depth-0"><a href="https://www.pressherald.com/contact/#place-obit">Place an Obituary</a></li>
</ul></div></div><div id="nav_menu-6" class="widget widget_nav_menu"><h2 class="widgettitle">Events</h2>
<div class="menu-events-container"><ul id="menu-events" class="menu"><li id="menu-item-735304" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-735304 depth-0"><a target="_blank" href="http://voices.centralmaine.com">Community Voices</a></li>
<li id="menu-item-961214" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-961214 depth-0"><a href="/bizforum">CM Business Breakfast Forum</a></li>
<li id="menu-item-735306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-735306 depth-0"><a target="_blank" href="/sourceawards">Source Sustainability Awards</a></li>
<li id="menu-item-735307" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-735307 depth-0"><a target="_blank" href="http://mainevoices.pressherald.com/">Maine Voices Live</a></li>
<li id="menu-item-735308" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-735308 depth-0"><a target="_blank" href="http://varsitymaine.com/vmea">Varsity Maine Awards</a></li>
</ul></div></div><div id="nav_menu-7" class="widget widget_nav_menu"><h2 class="widgettitle">Network</h2>
<div class="menu-network-container"><ul id="menu-network" class="menu"><li id="menu-item-349647" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-349647 depth-0"><a target="_blank" href="/career-opportunities/">Work Here</a></li>
<li id="menu-item-449877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-449877 depth-0"><a href="http://www.pressherald.com">PressHerald.com</a></li>
<li id="menu-item-449876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-449876 depth-0"><a href="http://www.mainetoday.com">MaineToday.com</a></li>
<li id="menu-item-735310" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-735310 depth-0"><a href="http://CoastalJournal.com">CoastalJournal.com</a></li>
<li id="menu-item-799779" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-799779 depth-0"><a href="http://sunjournal.com">SunJournal.com</a></li>
</ul></div></div><div id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><style>
	.tabbed-content-tabs__tab {
   
    padding: 10px 10px;
	}
	
		#adslot1,#adslot2,#adslot3,#adslot4 {
		width: auto !important;
	}

	
	.gform_not_found{display:none;}
	
	
	#native_ad{
		margin-bottom:20px;
	}
.notice-alert {
	font-family:'Open sans', san-serif;
	font-size:12px;
	line-height:16px;
	padding:3px 10px 10px 10px;
	/*border:1px solid #ccc;*/
	margin:0px 0px 28px;
	background: #f1f1f1;
}

.notice-alert a {
	color: #27aae1;
	text-decoration:none;
	font-weight:600;
}
.notice-alert a:hover {
	color: #333333 !important;
}

.notice-alert h3 {
	font-family:'Open sans', san-serif;
	font-weight:700;
	letter-spacing:-1px;
	font-size:20px;
	margin-top:10px;
	margin-bottom:8px;
}
</style>
<script>!function(){"use strict";if(/logout/.test(window.location.search)){var o=new Date,t="MSPAN_Paywall_user=0; domain=."+document.location.host.replace(/^\w+\./,"")+"; path=/; expires="+o.toGMTString(),e="MSPAN_Paywall_user=0; domain="+document.location.host+"; path=/; expires="+o.toGMTString();o.setHours(o.getHours()-1),document.cookie=t,document.cookie=e}}(),jQuery(function(){jQuery(".btf-block").wrapAll('<div class="btf-container"></div>')});</script>
<style>.cloudup_iframe_embed{width:100%;}
#menu-item-804481 .more-in h2 {
	visibility: hidden;
	position: relative;
}

#menu-item-804481 .more-in h2:after {
	visibility: visible;
	position: absolute;
	top: 0;
	left: 0;
	content: "More in Sports";
}
	.wxalert, .wxcurrent{top:-12px}
</style>
<style>
/*
Fix for category labels carets in Story Cluster
*/
.mtm-story-cluster li .category:after {
        content: ""; 
        background:transparent !important;
    }   
	.mtm-story-cluster li .category:hover {
		background:transparent !important;
	}
</style>
<style>
	/*
Fix for header treatments in homepage 1-Up Section Wells
*/
.mtm-section-wells .banner {
	border-top:none !important;
}

.mtm-section-wells .banner .section {
    padding-right: 0px !important;
    font-family: open sans,sans-serif;
    font-size: 14px !important;
    letter-spacing: 0px !important;
    text-transform: uppercase;
    color: #000 !important;
    background-color: #e6e6e6;
    width: 100% !important;
    padding-top: 5px;
    padding-bottom: 5px;
    padding-left: 10px;
    border-left: 4px solid #000;
}

.mtm-section-wells .banner .section a {
    text-decoration:none;
    color:#000;
}
.carousel-wrap .banner .section {
		display:none;
	}
</style>
<style>
/*
Fix for category labels on section fronts
*/
.mtm-small-main-col-right .mtm-newslist li p.category a {
        background:transparent !important;
        margin-left:-10px;
    }
    .mtm-small-main-col-right .mtm-newslist li p.category a::after {
        content: ""; 
        background:transparent !important;
    }   
	
.mtm-featured p.nolink{
		display:inline-block;
    margin-bottom: 8px;
    font-family: "Open sans",sans-serif;
    font-weight: 700;
    background-color: #000;
    text-transform: uppercase;
    color: #fff;
    padding-left: 10px !important;
    padding-right: 10px !important;
    font-size: 12px !important;
}
	/* Fix for temperature height in weather in header */
		body .wxalert, body .wxcurrent {
			top:-11px !important
	}

</style>
<script>

var console = {
   log: function(){}
};
	
var SlideDown_messages = [];

jQuery(function(){
	jQuery(".mtm-featured p.show-category").not(":has(a)").addClass("nolink");
});
</script>
<style>/* Fix for line wrap on Related Stories in middle section */
	.mtm-top-stories-masonry .related {
		max-width: 100%;
	}

</style>
<style>
/* Fix for mtm-section-wells at Mobile sizes */	
	@media screen and (max-width: 600px) {
		.mtm-section-wells {
			display:block !important;
		}
		.section-wells-wrap {
			display:block !important;
			margin-top:25px;
		}
	}
</style>
<style>
/* Fix for tabbed content at Mobile sizes */	
	.mtm-top-stories-masonry .related, .mtm-main-col .mtm-top-stories-masonry .related {
    width: 200%;
}
	@media screen and (max-width: 600px) {
		.mtm-main-col .mtm-top-stories-masonry .related {
    width: 100%;
}
		
	}
	
	
	.mtm-bottom-col .tabbed-content-panel .mtm-top-stories-masonry .related {
    width: 100%;
}
	
	
	
	.mtm-bottom-col .tabbed-content-panel .mtm-top-stories-masonry .related {
    width: 100%;
}
        @media screen and (max-width: 800px) {	
.mtm-main-col .tabbed-content .mtm-top-stories-masonry li, .mtm-main-col .mtm-top-stories-masonry li {
    max-width: 100%;
}
	}
	
</style>
<style>
/* FIX FOR HOMEPAGE RELATED LINKS WIDTH */
.mtm-top-stories-masonry .related ul li:first-child {
	min-width:100% !important;
	}
</style></div></div><div id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script>
/**
 * Stops error that prevents user's status bar update
 */
var SlideDown_messages = [];
	
</script>
<style>.mtm-leaderboard-pos1 {     background: none;     border-bottom: 1px solid #ccc;     padding-bottom: 13px; }@media screen and (max-width: 470px){ .sub-navigation ul{width:900px;}  }    .more-in .search form{       display:block;    }   
	.caption, .caption img {       width: 100%;       max-width: 100%;  }    .brightcove-wrap {       padding-bottom: 10px;    }     .BrightcoveExperience {       position: relative;       top: 0;       left: 0;       width: 100%;       height: auto;       min-height: 375px;    }         @media screen and (max-width: 600px) {       .no-mobile {          display: none;       }    }    @media only screen and (max-width: 600px) {       .paywall-callout {          display: none !important;       }       .paywall-callout-leavebehind {          display: none !important;       }    }     .kicker {             clear: both;          }     .mtm-top-stories-masonry li p {             display: none;          }               .mtm-top-stories-masonry .related {             margin-top: 10px;          }               .mtm-top-stories-masonry .related ul li {             display: none;          }               .mtm-top-stories-masonry .related ul li:first-child {             display: block;             margin-left: 8px;          }               .mtm-top-stories-masonry .related ul li:first-child a {             color: #000;             padding-left: 8px;             letter-spacing: -.5px;          }               .mtm-featured .related ul li a {             color: #000;          }               .mtm-featured .related ul {             margin-left: 6px;          }               .main-navigation .site-home-logo{                 background-image: url(https://www.centralmaine.com/wp-content/uploads/sites/2/2014/06/centralmaine-icon-white2.png);           } </style> <style>    .mtm-top-stories-masonry li:nth-child(even){    float: left;    clear: right; }.mtm-top-stories-masonry li:nth-child(2n+2), .mtm-main-col .mtm-top-stories-masonry li:nth-child(2n+2){float:left} </style>
<style type="text/css"> #iubenda-cs-banner { bottom: 0px !important; left: 0px !important; position: fixed !important; width: 100% !important; z-index: 99999998 !important; background-color: black; } .iubenda-cs-content { display: block; margin: 0 auto; padding: 20px; width: auto; font-family: Helvetica,Arial,FreeSans,sans-serif; font-size: 14px; background: #000; color: #fff;} .iubenda-cs-rationale { max-width: 900px; position: relative; margin: 0 auto; } .iubenda-banner-content > p { font-family: Helvetica,Arial,FreeSans,sans-serif; line-height: 1.5; } .iubenda-cs-close-btn { margin:0; color: #fff; text-decoration: none; font-size: 14px; position: absolute; top: 0; right: 0; border: none; } .iubenda-cs-cookie-policy-lnk { text-decoration: underline; color: #fff; font-size: 14px; font-weight: 900; } </style> <script type="text/javascript"> var _iub = _iub || []; _iub.csConfiguration = {"banner":{"applyStyles":false,"cookiePolicyLinkCaption":"https://centralmaine.com/cookie-policy"},"lang":"en","siteId":137864,"cookiePolicyUrl":"https://centralmaine.com/cookie-policy","cookiePolicyInOtherWindow":true,"consentOnButton":false,"cookiePolicyId":415238}; </script><script type="text/javascript" src="//cdn.iubenda.com/cookie_solution/safemode/iubenda_cs.js" charset="UTF-8" async></script>
</div></div><div id="custom_html-35" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<script> var mediaContent = "media\\:content,content";   jQuery(function() {  jQuery('.large-media-promo').after('<div /><div />'); } );  </script>
<style>   mtm-main-col .mtm-top-stories-masonry   {         overflow: hidden;     }</style><link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css"> <script type="text/javascript" src="//dev.mainetodaymedia.com/20160112-offers/main.js"> </script><script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/handlebars.js/4.0.5/handlebars.min.js"></script>  <script type="text/handlebars" id="village-soup-nav-item">  <li>     <a href="{{ link }}" onclick="ga('send', 'event', 'click', 'hovernav | Local Offers', '{{ title }}');">{{ title }} at {{company}}</a> </li> </script>  <script type="text/handlebars" id="village-soup-nav-featured-item">    {{#if image_source}} <div class="image-crop">     <a href="{{ link }}" onclick="ga('send', 'event', 'click', 'hovernav | Local Offers', '{{ title }}');">     <img width="250" height="250" src="{{ image_source }}" class="attachment-thumbnail wp-post-image" alt="{{ title }}">  </a>  </div>  {{/if}} <div class="category">Local Offers</div>  <div class="nav-headline">     <a href="{{ link }}" onclick="ga('send', 'event', 'click', 'hovernav | Local Offers', '{{ title }}');">{{ title }}</a> </div> <a href="{{ link }}">{{ description }} at {{company}}</a> </script> <style>  .more-container {  width: 100%;   display: block;  } .more-promo {     position: relative;     clear: both;     margin-top: 0px;     margin-bottom: 20px;     padding-bottom: 12px;     text-align: center; } .post-offer {    font-family: 'Open sans',sans-serif;   font-size: 11px;  text-align: left;    padding:0 10px; } .post-offer a {   color: #EF4136;   text-decoration: none; } .post-offer a:hover {  text-decoration: underline;   color: #000; }  #local-offers {     background: url("//dev.mainetodaymedia.com/20160115-offers/theme/vs/img/offers-btn.png") no-repeat scroll left top rgba(0, 0, 0, 0);     display: block;     height: 60px;     width: 115px;     margin-bottom: 0px;     margin-top: -9px;     margin-left:10px;   float: left; } #local-offers:hover{ background-position: 0 -63px; } #local-notes {     background: url("https://dev.mainetodaymedia.com/20160115-offers/theme/vs/img/notes-btn.png") no-repeat scroll left top rgba(0, 0, 0, 0);     display: block;     height: 60px;     width: 100px;     margin-bottom: 0px;     margin-top: -11px;     float: left; } #local-notes:hover{ background-position: 0 -63px; }   .more-offers {    margin-top:5px;   margin-bottom:8px;   font-size:13px;   font-weight:400;  line-height:16px;    letter-spacing:.4px; } .more-offers a {     margin-top: 10px;     padding: 7px 22px;     border: 2px solid #c62828;     background: #c62828;     font-size: 12px;     letter-spacing: 2px;     font-family:'Open sans',sans-serif;     -webkit-transition-duration: .25s;     transition-duration: .25s;     color: #fff;     text-transform: uppercase;     text-decoration: none; } .more-offers a:hover{    color:#c62828;    background:#fff;  cursor:pointer;   -webkit-transition-duration:.25s;   transition-duration:.25s; }  #village-soup{  width:300px;   margin:0 auto;    font-size:12px;   font-family:Arial, sans-serif }  #village-soup .tabs{    background-color:#c62828;  width: 100%;   text-align: left;    height:35px;   padding-left: 10px;  position:relative;   top:1px;    z-index:2;  cursor:pointer }  #village-soup .tabs div{   float:left;    text-align:center;   cursor:pointer; }  #village-soup .tabs span {   font-family: 'Open Sans Condensed', sans-serif;    color:#fff;    font-weight: 700;    letter-spacing: 1px;    font-size: 22px;  text-transform: uppercase;    float: left; }  #village-soup .tabs div.active{    font-weight:bold;    background-position: 0 -63px; }  #village-soup ul{    width:100%;    margin-bottom:25px;  padding:0;  border-bottom:0;  overflow:hidden;  display:none }  #village-soup ul#feed1{   display:block; }  #village-soup li{    list-style:none;        padding:3px 2px 10px 7px;  height:auto;   box-sizing:border-box; }  #village-soup li:nth-child(odd){   }  #village-soup p{    padding:0;  margin:0 }  #village-soup a {    text-decoration:none;   color:#333;    font-weight:bold }  .search-desc {     text-transform: none !important;     font-family: 'Lusitana', serif !important;     padding-right: 5px;     font-size: 15px !important;     padding-top: 8px;     letter-spacing: .2px; } .more-in .mtm-search-box {     max-width: 155px !important;     margin-right: 10px !important; }  /*# sourceMappingURL=main.css.map */ </style><style>.utility-logo-large {left:130px; top:8px}.featured-headline a{text-decoration:none;color:black;} .local-offers.menu-item-476996:before {     content: "\f02c";     font-family: FontAwesome;     font-style: normal;     font-weight: normal;     text-decoration: inherit;         color: #ffffff;     margin-right: -10px; } .loffers{  moz-column-count: 2;     -moz-column-gap: 20px;     -webkit-column-count: 2;     -webkit-column-gap: 20px;     column-count: 2;     -webkit-column-break-inside: avoid;     page-break-inside: avoid;     break-inside: avoid-column;     display: block;   }  .loffers li{ list-style: none;     font-family: 'Open sans',sans-serif;     font-size: 13px;  }  .loffers li a{ color: #000;     text-decoration: none;  } .local-offers.menu-item-476996:before{content:"";} </style>
<script>(function(){    var now = new Date();    var cookieName = new RegExp( 'MSPAN_Paywall_views_' + now.getMonth() );        window.MSPAN = {       Paywall: {          totalViews: function(){             var cookies = document.cookie.split('; ');             var val = 0;              if( ! cookieName.test(document.cookie ) ){                return 0;             }             for(var i = 0; i < cookies.length; i++){                if(cookieName.test(cookies[i])){                   val = parseInt(cookies[i].split('=')[1]);                }             }             return val;          }       }    }; }());
</script>
<script>
	/*
setTimeout(function(){
jQuery("#village-soup").detach().insertAfter("#pos_2_atf_300x250-wrap");
}, 2000);
*/
</script></div></div><div id="custom_html-38" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script>
 function emailSubmission(){
	 jQuery(".paywall-module").empty().html("<div id='emailConfirm'><b>Thanks for signing up. Check your email for an activation link.</b></div>");	 
 }
	
	jQuery(window).ready(function() {
	var MTM_isGuest = (function($, undefined){
   'use strict';

   var cookies = document.cookie.split(';');
   var userCookie;

   for( var i = 0; i < cookies.length; i++ ){
      if( /mspan_paywall_user/i.test(cookies[i]) ){
         userCookie = JSON.parse(decodeURIComponent(cookies[i].split('=')[1]));
         if( userCookie.name === 'Guest' && userCookie.type ){
            if( userCookie.type === 'trial' ){
              memic();
            }
         }
      }
   }

   return false;
}(jQuery));
	});
	
function memic(){
	
	jQuery('.login ').hide().after("<div class='memic'><div>FREE ACCESS<br /> from</div><a href='http://pubads.g.doubleclick.net/gampad/clk?id=4846962888&iu=/6119/centralmaine.com' target='_blank'><img src='https://multifiles.pressherald.com/uploads/sites/4/2018/10/MEMIC-25th-Anniversary-logo-color.png' /></a></div>");	
}

</script>
<style>
	.memic div{color:#ffffff;font-weight:bold;height:40px;padding:7px 10px;background:#008dde;float:left;margin-right:5px;}
	.memic{float:right;}
	.memic img{height:40px; width:auto;margin-right:5px;margin-top:5px;}
	#emailConfirm{
		width:100%;
		height:40px;
		background-color:#00000;
		color:#ffffff;
		font-size:20px;
		font-family: "Open sans", sans-serif;
		text-align:center;
	}
@media (max-width : 600px) {
	.memic div{display:none;}
	}
</style></div></div> </div>
<div class="Copyright footer-menu">
<div class="menu-section-footer-container"><ul id="menu-section-footer" class="menu"><li id="menu-item-733423" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-733423 depth-0"><a href="https://www.centralmaine.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-852399" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-852399 depth-0"><a href="https://www.centralmaine.com/cookie-policy/">Cookie Policy</a></li>
<li id="menu-item-733424" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-733424 depth-0"><a href="https://www.centralmaine.com/terms-use/">Terms of Use</a></li>
<li id="menu-item-733425" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-733425 depth-0"><a href="https://www.centralmaine.com/commenting-guidelines/">Commenting Guidelines</a></li>
<li id="menu-item-733427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-733427 depth-0"><a href="http://www.mainenotices.com/">Public Notices</a></li>
<li id="menu-item-733435" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-733435 depth-0"><a href="http://mainetoday.mycapture.com/mycapture/index.asp">Purchase a Photo</a></li>
<li id="menu-item-733436" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-733436 depth-0"><a href="/order">Subscribe</a></li>
</ul></div> </div>
</div>
</div>
<div class="mtm-footer-social">
<div class="mtm-footer-social__copyright">
<span class="copyright">&copy; 2018</span>
| <span class="rights">All Rights Reserved</span>
| <strong class="blog-name">Kennebec Journal and Morning Sentinel</strong>


</div>
</div>
<div id="pos_f_320x50">
<script>
 googletag.cmd.push(function() { googletag.display('pos_f_320x50'); });
</script>
</div>
<div class="mtm-login-skin" style="">
</div>
 <div id="fb-root"></div>
<script>(function(d, s, id) {
				var js, fjs = d.getElementsByTagName(s)[0];
				if (d.getElementById(id))
					return;
				js = d.createElement(s);
				js.id = id;
				js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=754222714628811";
				fjs.parentNode.insertBefore(js, fjs);
			}(document, 'script', 'facebook-jssdk'));</script>
<link rel='stylesheet' id='gforms_reset_css-css' href='https://www.centralmaine.com/wp-content/plugins/gravityforms/css/formreset.min.css?ver=2.2.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_formsmain_css-css' href='https://www.centralmaine.com/wp-content/plugins/gravityforms/css/formsmain.min.css?ver=2.2.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_ready_class_css-css' href='https://www.centralmaine.com/wp-content/plugins/gravityforms/css/readyclass.min.css?ver=2.2.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_browsers_css-css' href='https://www.centralmaine.com/wp-content/plugins/gravityforms/css/browsers.min.css?ver=2.2.6.1' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var paywall = {"global":{"count":"6","promo":"extra2","returnPath":"https:\/\/www.centralmaine.com\/wp-content\/themes\/mainetoday\/returnpath.php","currentPage":"https:\/\/www.centralmaine.com\/?p=1128310","resetCode":"","bypassCode":"MaYTh34ce18","faq":"https:\/\/myaccount.kjonline.com\/faqs.php","isSingle":1},"adBlockLinks":["https:\/\/dev.mainetodaymedia.com\/2017-adblock\/kj.html","https:\/\/dev.mainetodaymedia.com\/2017-adblock\/ms.html"],"adBlockEnabled":"","stubLinks":"https:\/\/dev.mainetodaymedia.com\/paywall\/overlays\/wp-stub-cm.html","privateBlockEnabled":"","privateURLs":"","category_list":[{"term_id":120,"name":"Sports","slug":"sports","term_group":0,"term_taxonomy_id":120,"taxonomy":"category","description":"","parent":0,"count":23082,"filter":"raw","cat_ID":120,"category_count":23082,"category_description":"","cat_name":"Sports","category_nicename":"sports","category_parent":0},{"term_id":125,"name":"Varsity Maine","slug":"highschoolsports","term_group":0,"term_taxonomy_id":125,"taxonomy":"category","description":"","parent":120,"count":4991,"filter":"raw","cat_ID":125,"category_count":4991,"category_description":"","cat_name":"Varsity Maine","category_nicename":"highschoolsports","category_parent":120}],"ignored_categories":["125","257"],"should_ignore":"","absence_after":"5","absence_gift":"5","age":"1","hardURL":"","hardPaywallAfter":"-1"};
var SlideDown_messages = ["","","","","","","","","",""];
var SlideDown_special = {"text":"","image":"","faq":"https:\/\/myaccount.kjonline.com\/faqs.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-content/plugins/mtm-paywall//js/paywall-redo.js?ver=1540483649'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"mtmcm"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"1128310 https:\/\/www.centralmaine.com\/2018\/11\/19\/for-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win\/","disqusShortname":"mtmcm","disqusTitle":"For Portland High basketball coach Joe Russo, a battle with cancer is providing his biggest win","disqusUrl":"https:\/\/www.centralmaine.com\/2018\/11\/19\/for-portland-high-basketball-coach-joe-russo-a-battle-with-cancer-is-providing-his-biggest-win\/","postId":"1128310"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.16'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201847'></script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-includes/js/jquery/ui/effect-slide.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var MTMMailChimp = {"nonce":"aacf2e0044","action":"mtm_mailchimp_subscribe","ajaxurl":"https:\/\/www.centralmaine.com\/wp-admin\/admin-ajax.php"};
var mtmSettings = {"isSingular":"true","isHome":"false","isComments":"false","url":"https:\/\/www.centralmaine.com"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-content/themes/mainetoday/assets/js/mainetoday.min.js?ver=1539871469'></script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-content/themes/mainetoday/assets/js/mtm-datepicker.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-content/themes/mainetoday-centralmaine/assets/js/mtm-child.min.js?ver=1530269452'></script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-content/plugins/gravityforms/js/jquery.json.min.js?ver=2.2.6.1'></script>
<script type='text/javascript' src='https://www.centralmaine.com/wp-content/plugins/gravityforms/js/gravityforms.min.js?ver=2.2.6.1'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201847.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.9',blog:'140757421',post:'1128310',tz:'-5',srv:'www.centralmaine.com'} ]);
	_stq.push([ 'clickTrackerInit', '140757421', '1128310' ]);
</script>
<script type="text/javascript">
	var disqus_shortname = 'mtmcm';

	(function () {
		var s = document.createElement('script'); s.async = true;
		s.type = 'text/javascript';
		s.src = '//' + disqus_shortname + '.disqus.com/count.js';
		(document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
	}());
 </script>
<script type='text/javascript'>
      var _sf_async_config = _sf_async_config || {};
      /** CONFIGURATION START **/
       _sf_async_config.sections= 'sports,highschoolsports';

      _sf_async_config.authors = Utils.getAuthor();



      /** CONFIGURATION END **/
      (function() {
          function loadChartbeat() {
              window._sf_endpt = (new Date()).getTime();
              var e = document.createElement('script');
              e.setAttribute('language', 'javascript');
              e.setAttribute('type', 'text/javascript');
              e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');

              document.body.appendChild(e);
          }
          var oldonload = window.onload;
          window.onload = (typeof window.onload != 'function') ?
              loadChartbeat : function() {
                  oldonload();
                  loadChartbeat();
              };

          })();
      </script>
</body>
</html>